Bug 457670 - rt61pci: possible recursive locking detected
rt61pci: possible recursive locking detected
Status: CLOSED DUPLICATE of bug 457592
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 05:21 EDT by David Nielsen
Modified: 2008-08-12 11:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-12 11:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2008-08-03 05:21:02 EDT
Description of problem:
I am seeing the following lockdep warning at boot as well as experiencing random frequent lockups. I suspect the two are related but am not sure.

=============================================
[ INFO: possible recursive locking detected ]
2.6.27-0.211.rc1.git3.fc10.x86_64 #1
---------------------------------------------
rt61pci/1206 is trying to acquire lock:
 (_xmit_IEEE80211#2){-...}, at: [<ffffffffa01e7c52>] ieee80211_scan_completed+0x142/0x2e2 [mac80211]

but task is already holding lock:
 (_xmit_IEEE80211#2){-...}, at: [<ffffffffa01e7c52>] ieee80211_scan_completed+0x142/0x2e2 [mac80211]

other info that might help us debug this:
3 locks held by rt61pci/1206:
 #0:  ((name)){--..}, at: [<ffffffff81054572>] run_workqueue+0xb6/0x207
 #1:  (&(&local->scan_work)->work){--..}, at: [<ffffffff81054572>] run_workqueue+0xb6/0x207
 #2:  (_xmit_IEEE80211#2){-...}, at: [<ffffffffa01e7c52>] ieee80211_scan_completed+0x142/0x2e2 [mac80211]

stack backtrace:
Pid: 1206, comm: rt61pci Not tainted 2.6.27-0.211.rc1.git3.fc10.x86_64 #1

Call Trace:
 [<ffffffff8106686d>] __lock_acquire+0x790/0xaa7
 [<ffffffff810551e0>] ? queue_delayed_work_on+0xe4/0xf8
 [<ffffffffa01e7c52>] ? ieee80211_scan_completed+0x142/0x2e2 [mac80211]
 [<ffffffff81066c1a>] lock_acquire+0x96/0xc3
 [<ffffffffa01e7c52>] ? ieee80211_scan_completed+0x142/0x2e2 [mac80211]
 [<ffffffff8130c718>] _spin_lock+0x2b/0x58
 [<ffffffffa01e7c52>] ieee80211_scan_completed+0x142/0x2e2 [mac80211]
 [<ffffffff81054572>] ? run_workqueue+0xb6/0x207
 [<ffffffffa01e80a3>] ieee80211_sta_scan_work+0xb4/0x1ad [mac80211]
 [<ffffffff810545bc>] run_workqueue+0x100/0x207
 [<ffffffffa01e7fef>] ? ieee80211_sta_scan_work+0x0/0x1ad [mac80211]
 [<ffffffff810547c0>] worker_thread+0xfd/0x111
 [<ffffffff810584f1>] ? autoremove_wake_function+0x0/0x3d
 [<ffffffff810546c3>] ? worker_thread+0x0/0x111
 [<ffffffff81058174>] kthread+0x4e/0x7b
 [<ffffffff810118a9>] child_rip+0xa/0x11
 [<ffffffff81010bbe>] ? restore_args+0x0/0x30
 [<ffffffff81058126>] ? kthread+0x0/0x7b
 [<ffffffff8101189f>] ? child_rip+0x0/0x11

Version-Release number of selected component (if applicable):
2.6.27-0.211.rc1.git3.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install 2.6.27-0.211.rc1.git3.fc10.x86_64
2. boot
  
Actual results:
Note lockdep warning, and also notice how the machine likes to lock up at rather random times.

Expected results:

Additional info:
Comment 1 John W. Linville 2008-08-12 11:39:24 EDT

*** This bug has been marked as a duplicate of bug 457592 ***

Note You need to log in before you can comment on or make changes to this bug.