Bug 457704 - mouse-over other users shows my email address
mouse-over other users shows my email address
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
:
: 457729 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 22:48 EDT by Jens Petersen
Modified: 2013-06-24 00:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 12:25:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 patch to fix login names appearing when mouseover usernames in bug reports (758 bytes, patch)
2008-08-04 09:09 EDT, Noura El hawary
dkl: review+
Details | Diff

  None (edit)
Description Jens Petersen 2008-08-03 22:48:09 EDT
Description of problem:
With the new bugzilla when I bring the mouse pointer over the name of a bugzilla user
(eg in the Assigned To or CC fields etc) the mouse-over text (tooltip) shows
my email address not the address of the user under the pointer.

How reproducible:
every time

Steps to Reproduce:
1. Point to a username mailto link in a bug.
  
Actual results:
1. My email address is shown.

Expected results:
1. The user's email address to be shown.
Comment 1 Noura El hawary 2008-08-04 09:09:03 EDT
Created attachment 313358 [details]
v1 patch to fix login names appearing when mouseover usernames in bug reports

Thanks for reporting the issue Jens.

The attached patch should fix the problem , I have applied it to bz-web2 and seems to work fine there so now whenever you move the mouse over a name it should display the login name for that user not for the logged in user.

Cheers,
Noura
Comment 2 Noura El hawary 2008-08-04 09:30:57 EDT
*** Bug 457729 has been marked as a duplicate of this bug. ***
Comment 3 David Lawrence 2008-08-04 11:18:08 EDT
Comment on attachment 313358 [details]
v1 patch to fix login names appearing when mouseover usernames in bug reports

Looks good Noura. We need to verify that this is also an upstream bug and submit a bug for them as well. I don't believe we changed anything in this part of the code ourselves.

Dave
Comment 4 Noura El hawary 2008-08-04 12:25:45 EDT
Thanks for the review Dave, committed to cvs.

Noura
Comment 5 Frédéric Buclin 2008-08-04 13:38:46 EDT
(In reply to comment #3)
> (From update of attachment 313358 [details])
> Looks good Noura. We need to verify that this is also an upstream bug

Not an upstream bug. We don't use bug_user in this template. I cannot reproduce this bug in 3.2 RC1.
Comment 6 David Lawrence 2008-08-04 13:48:07 EDT
(In reply to comment #5)
> (In reply to comment #3)
> > (From update of attachment 313358 [details] [details])
> > Looks good Noura. We need to verify that this is also an upstream bug
> 
> Not an upstream bug. We don't use bug_user in this template. I cannot reproduce
> this bug in 3.2 RC1.

Yeah we figured out that it was a typo in the portion of our code that hides the email addresses for non-logged in users. Should be fixed now.

Dave
Comment 7 Jens Petersen 2008-08-04 19:58:53 EDT
Thanks!  Looks good now. :)

Note You need to log in before you can comment on or make changes to this bug.