Bug 457766 - Page layout on bug display too wide
Page layout on bug display too wide
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
: 457853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 11:01 EDT by Tomas Mraz
Modified: 2013-06-23 22:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 12:55:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the bug display page. (202.30 KB, image/png)
2008-08-04 11:01 EDT, Tomas Mraz
no flags Details
upstream bugzilla (134.35 KB, image/png)
2008-08-13 16:38 EDT, James M. Leddy
no flags Details

  None (edit)
Description Tomas Mraz 2008-08-04 11:01:10 EDT
Created attachment 313364 [details]
Screenshot of the bug display page.

The page layout on bug display is too wide to fit in a window with reasonable width after upgrade to Bugzilla 3.2.

This happens to me with Firefox on Fedora 8.

As you can see the right column in the bug report heading could be made narrower to fit. The text entry boxes seem to be unnecessarily wide.
Comment 1 David Lawrence 2008-08-07 12:55:43 EDT
Thanks for the report. We are shortening the input sizes to 40 instead of 60. Should be in the next update.

Dave
Comment 2 David Lawrence 2008-08-07 12:59:31 EDT
*** Bug 457853 has been marked as a duplicate of this bug. ***
Comment 3 James M. Leddy 2008-08-13 16:33:24 EDT
(In reply to comment #1)
> Thanks for the report. We are shortening the input sizes to 40 instead of 60.
> Should be in the next update.
> 
> Dave

Dave,

I'd like your thoughts on this.  The screenshot in the bug report I filed did 3 things:

1. Changed fix-length widths (now at 40) to 'style="width: 100%;"'
2. get rid of white-space: nowrap from #bugzilla-body th{ global.css line92
3. get rid of the spacer column or make it a small percentage of the width.

I'm using the new version and it still looks wonky.  I keep my browser relatively large and have a widescreen desktop too, so I wouldn't be surprised if this happened to most people.

As for this being an upstream bug, I've included a screenshot of bugzilla.mozilla.org at a browser width smaller than I usually use, and everything scales.
Comment 4 James M. Leddy 2008-08-13 16:38:14 EDT
Created attachment 314257 [details]
upstream bugzilla
Comment 5 Tomas Mraz 2008-08-13 16:45:41 EDT
The real solution would be to put all the longer fields in the header in the first column and all the short fields in the second one.
This way the least screen estate is wasted.
Comment 6 David Lawrence 2008-08-13 17:52:19 EDT
(In reply to comment #4)
> Created an attachment (id=314257) [details]
> upstream bugzilla

To be fair, that screen shot is also when a user is not logged in which displays considerably less input fields. If you log in you will see more real estate being consumed.

Also b.m.o normally customizes their interface beyond what the stock upstream code has so they could be doing things to make the page display differently.

Also they are not yet running the 3.2 code base so the UI is significantly different than what we are using. They are planning on updating very soon to the new code which will make their page look more like ours. For a better example of what the upstream page looks like compared to ours, refer to:

https://landfill.bugzilla.org/bugzilla-3.2-branch/

Dave

Note You need to log in before you can comment on or make changes to this bug.