Bug 457803 - preupgrade RPM missing dependency on gtk (or missing documentation on console usage)
preupgrade RPM missing dependency on gtk (or missing documentation on console...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 457968 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-04 14:29 EDT by Daniel Wang
Modified: 2008-11-26 01:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 01:13:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Wang 2008-08-04 14:29:09 EDT
Description of problem:
The RPMs for preupgrade on Fedora 9 and Rawhide (as of 8/4/08) lack an explicit dependency on GTK.  This is a pretty trivial bug, which only means that yum will let you install preupgrade without making you install its dependencies.

Version-Release number of selected component (if applicable):
0.9.3-3.fc9
0.9.3-3.fc10

How reproducible:
Every time.

Steps to Reproduce:
1. On a system without GTK installed, "yum install preupgrade".  yum happily installs preupgrade without pulling in any additional dependencies.
2. Try "preupgrade" or "preupgrade --help"
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 19, in <module>
    import gtk
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 79, in <module>
    _init()
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 67, in _init
    _gtk.init_check()
RuntimeError: could not open display


Expected results:
Maybe there's an option to run preupgrade w/o GTK, but I couldn't figure it out using "preupgrade --help" or by checking in /usr/share/doc/preupgrade-0.9.3 or 
http://fedoraproject.org/wiki/Features/PreUpgrade .

If I'm not mistaken, this means that I should get warned about needing GTK when installing preupgrade, or that preupgrade should have a non-gtk-requiring mode whose usage I can grok w/o peeping at its source-code.

Additional info:
This seems pretty trivial to fix (by adding a dep to the .spec), but not too important overall.  Impact is low, but I thought someone should know.
Comment 1 Will Woods 2008-08-12 17:57:13 EDT
*** Bug 457968 has been marked as a duplicate of this bug. ***
Comment 2 Eric Paris 2008-08-12 18:33:23 EDT
Also like to point out from the other bug that just got dupped in.

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-cli.py", line 26, in <module>
    import preupgrade
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 27, in
<module>
    import xf86config
ImportError: No module named xf86config

Install pyxf86config.x86_64
Comment 3 Will Woods 2008-08-13 10:38:47 EDT
These are both fixed in bzr. A new preupgrade release will appear soonish. Before F10, anyway.
Comment 4 Fedora Update System 2008-10-23 12:36:58 EDT
preupgrade-0.9.8-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 5 Fedora Update System 2008-10-23 12:40:15 EDT
preupgrade-0.9.8-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 6 Fedora Update System 2008-11-11 21:58:33 EST
preupgrade-0.9.9-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 7 Fedora Update System 2008-11-11 21:59:45 EST
preupgrade-0.9.9-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 8 Fedora Update System 2008-11-21 18:48:58 EST
preupgrade-1.0.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.0.0-1.fc10
Comment 9 Fedora Update System 2008-11-26 01:12:42 EST
preupgrade-1.0.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-11-26 01:13:28 EST
preupgrade-1.0.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-11-26 01:21:56 EST
preupgrade-1.0.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.