Bug 458213 - [PATCH] Make iscsid wake up less when idle
[PATCH] Make iscsid wake up less when idle
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iscsi-initiator-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andy Grover
Fedora Extras Quality Assurance
: FutureFeature, Patch
: 819065 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-08-06 21:04 EDT by Adam Jackson
Modified: 2015-06-15 00:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-15 00:49:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch (2.19 KB, patch)
2008-08-06 21:11 EDT, Adam Jackson
no flags Details | Diff
open-iscsi-2.0-poll-less.patch (2.33 KB, patch)
2010-08-26 13:56 EDT, Adam Jackson
no flags Details | Diff

  None (edit)
Description Adam Jackson 2008-08-06 21:04:05 EDT
Description of problem:

libvirt pulls in iscsi-initiator-utils for some possibly valid reason.  i-i-u enables its initscript by default for some possibly valid reason.  iscsid wakes up four times a second to poll for nonexistent actor threads, for absolutely no reason.

We should at least not wake up so much.  Attached patch does at least something close to the right thing.  I've not tested it in an iscsi configuration, because I don't have one, but it certainly doesn't wake up uselessly any more.  It's possibly racy, in that i don't know if the actor refcount needs to be done with atomic operations.
Comment 1 Adam Jackson 2008-08-06 21:11:50 EDT
Created attachment 313656 [details]
patch
Comment 2 John Poelstra 2008-10-15 22:40:00 EDT
This bug has been triaged
Comment 3 Adam Jackson 2010-08-26 13:56:51 EDT
Created attachment 441292 [details]
open-iscsi-2.0-poll-less.patch

Updated the patch to account for the event loop being moved around.
Comment 4 Adam Jackson 2012-04-17 15:33:27 EDT
Still valid...
Comment 5 Mike Christie 2012-05-04 14:21:12 EDT
*** Bug 819065 has been marked as a duplicate of this bug. ***
Comment 6 Adam Jackson 2013-02-03 16:26:09 EST
I filed this bug about... 54 months ago, if my math is right.  Today I checked in my F19 virtual machine, and I _still_ have an iscsid waking up five times a second to do absolutely nothing.
Comment 7 Andy Grover 2014-10-03 12:16:24 EDT
That patchset was rejected upstream, there's some potential for zombie processes, apparently. I'm looking at this now.
Comment 8 Andy Grover 2015-01-16 18:47:50 EST
Progress! Patches accepted upstream.

Note You need to log in before you can comment on or make changes to this bug.