Bug 458242 - nfsnobody gid is wrong
nfsnobody gid is wrong
Status: CLOSED DUPLICATE of bug 485379
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 04:39 EDT by Allen Kistler
Modified: 2009-03-25 20:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 20:15:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Allen Kistler 2008-08-07 04:39:42 EDT
Description of problem:
nfsnobody gid is 492 in /etc/passwd and /etc/group.  However all_squash on
exports still uses 65534 (which I think is correct).

Version-Release number of selected component (if applicable):
nfs-utils-1.1.3-2.fc10

How reproducible:
Always

Steps to Reproduce:
1. Look in /etc/passwd and /etc/group
  
Actual results:
gid is listed as 492

Expected results:
gid is listed as 65534

Additional info:
Exporting a writable directory as all_squash, mounting it on another machine,
and creating a file from that machine causes the file to be created with gid
65534.  However then "ls -l" lists its ownership as "nfsnobody 65534" instead of
as "nfsnobody nfsnobody."

This bug is for F10-Alpha.
See also Bug 455980 for the same thing in F9.
Comment 1 Bug Zapper 2008-11-25 21:41:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Allen Kistler 2009-03-25 20:15:38 EDT
Since I've added a patch for Bug 485379, which is the same as this one except for F11-test, I'm closing this one in favor of that one.

*** This bug has been marked as a duplicate of bug 485379 ***

Note You need to log in before you can comment on or make changes to this bug.