Bug 458361 - RAID0 support broken in Fedora core 10 Alpha
RAID0 support broken in Fedora core 10 Alpha
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 459448 (view as bug list)
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-08-07 15:19 EDT by Yves Desgagne
Modified: 2008-10-03 17:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 16:06:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kickstart file (811 bytes, text/plain)
2008-08-07 15:19 EDT, Yves Desgagne
no flags Details
UI screen capture (876.29 KB, image/pjpeg)
2008-08-07 15:21 EDT, Yves Desgagne
no flags Details
shift-f3 debug info (870.04 KB, image/pjpeg)
2008-08-07 15:25 EDT, Yves Desgagne
no flags Details
shift-f4 debug info (852.49 KB, image/pjpeg)
2008-08-07 15:25 EDT, Yves Desgagne
no flags Details
shift-f5 debug info (849.69 KB, image/pjpeg)
2008-08-07 15:26 EDT, Yves Desgagne
no flags Details
Beyond end of device (849.79 KB, image/pjpeg)
2008-10-03 17:55 EDT, Yves Desgagne
no flags Details

  None (edit)
Description Yves Desgagne 2008-08-07 15:19:49 EDT
Created attachment 313731 [details]
Kickstart file

Description of problem:

Installer cannot create partitions on RAID0 volume. The installer complains about device capacity exceeded.

How reproducible:

On an Asus motherboard P4C800 deluxe using the onboard Promise fastrack 378 raid controller with a single raid volume configured as raid 0. The same problem is also reproducible with the onboard intel raid controller with a raid 0 volume.

The raid volume is composed of 2 x 80 GB disks in raid 0 for a total of ~152 GB volume. A swap partitons of 8 GB is created and a / parttion is created with the rest of the available space.

1. Install the i386 Fedora 10 Alpha using the DVD
2. Point the install to a kickstart file (see attachement). Same problem occured without a KS file and partitions created manually.
3. At partition creation the instller will stop complaining about device capacity exceeded.

Actual results:

Installer stop at partition creation.

Expected results:

Parttions created and instller shall move the the next step.

Additional info:

Same setup was able to run Fedora core 8 and 9 without any problems.
Comment 1 Yves Desgagne 2008-08-07 15:21:12 EDT
Created attachment 313733 [details]
UI screen capture
Comment 2 Yves Desgagne 2008-08-07 15:25:01 EDT
Created attachment 313735 [details]
shift-f3 debug info
Comment 3 Yves Desgagne 2008-08-07 15:25:45 EDT
Created attachment 313736 [details]
shift-f4 debug info
Comment 4 Yves Desgagne 2008-08-07 15:26:21 EDT
Created attachment 313737 [details]
shift-f5 debug info
Comment 5 Chris Lumens 2008-08-26 10:03:17 EDT
*** Bug 459448 has been marked as a duplicate of this bug. ***
Comment 6 Andy Lindeberg 2008-09-03 16:06:39 EDT
This should be fixed Rawhide. Please give it a try and let us know if you have any problems.
Comment 7 Yves Desgagne 2008-10-03 17:54:43 EDT
I confirm that the install is now able to proceed with the FC10 Beta DVD.

I did notice that multiples attemps are made beyond the end of device. See last attachment. Is this normal???
Comment 8 Yves Desgagne 2008-10-03 17:55:38 EDT
Created attachment 319428 [details]
Beyond end of device

Note You need to log in before you can comment on or make changes to this bug.