Bug 458404 - x-ogg-skeleton element reported as missing when playing many Ogg Theora videos
x-ogg-skeleton element reported as missing when playing many Ogg Theora videos
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
: 468853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 21:00 EDT by David Nielsen
Modified: 2008-11-19 09:52 EST (History)
6 users (show)

See Also:
Fixed In Version: 0.10.20-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 09:52:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 537599 None None None Never

  None (edit)
Description David Nielsen 2008-08-07 21:00:37 EDT
Description of problem:
I've noticed that when playing many Ogg Theora videos I get an error telling me I am lacking the x-ogg-skeleton element. However this being Ogg Theora, the only video format we play out of the box I would expect this to work without problems.

Version-Release number of selected component (if applicable):
gstreamer-0.10.20-1.fc10.x86_64
gstreamer-plugins-good-0.10.9-1.fc10.x86_64
gstreamer-plugins-base-0.10.20-1.fc10.x86_64


How reproducible:
100%

Steps to Reproduce:

1. download and open example video in totem or banshee. http://blip.tv/file/get/Geeko-GregKHTalksAboutTheLinuxKernel503.ogg
  
Actual results:
Note how a dialog is thrown up complaining that a gstreamer element is missing, namely the x-ogg-skeleton one.

Expected results:
Playback of Ogg Theora video

Additional info:
Comment 1 John (J5) Palmieri 2008-08-08 09:11:19 EDT
Also happens here: http://www.gnome.org/~federico/docs/rpm2git/rpm2git-intro.ogg


It seems to happen when RecordMyDesktop is used.

#  Jeff Ollie Says:
August 7th, 2008 at 10:36 pm e

The Skeleton data is a format for embedding metadata in Ogg streams. I’ve seen this happen with other Oggs produced with recordmydesktop - Skeleton support seems to have been added recently.

http://xiph.org/ogg/doc/skeleton.html
http://wiki.xiph.org/index.php/Ogg_Skeleton


So my guess is it is in our libraries but gstreamer hasn't registered the mime-type.
Comment 2 John (J5) Palmieri 2008-08-08 09:12:37 EDT
Oh and I should note the movie actually plays for me after I hit cancel on codina.
Comment 3 Jeffrey C. Ollie 2008-08-08 23:40:31 EDT
You can do a little more digging into the Ogg file with "ogginfo" from the vorbis-tools package:

[jcollie@lt21223 ~]$ ogginfo Geeko-GregKHTalksAboutTheLinuxKernel503.ogg 
Processing file "Geeko-GregKHTalksAboutTheLinuxKernel503.ogg"...

New logical stream (#1, serial: 771150c2): type skeleton
New logical stream (#2, serial: 5c8876f4): type theora
New logical stream (#3, serial: 369f373a): type vorbis
[...]

[jcollie@lt21223 ~]$ ogginfo rpm2git-intro.ogg 
Processing file "rpm2git-intro.ogg"...

New logical stream (#1, serial: 360bc2c1): type skeleton
New logical stream (#2, serial: 1bf56800): type theora
New logical stream (#3, serial: 1f4f58a4): type vorbis
[...]

But for example if you check the spacewalk video recently published in the Red Hat Magazine blog:

http://www.redhat.com/v/magazine/ogg/spacewalk.ogg

[jcollie@lt21223 ~]$ ogginfo spacewalk.ogg 
Processing file "spacewalk.ogg"...

New logical stream (#1, serial: 024951b0): type theora
New logical stream (#2, serial: 124f06d4): type vorbis
[...]

Skeleton support appears to have been added in version 0.3.7.1 of recordmydesktop...
Comment 4 Jeffrey C. Ollie 2008-08-08 23:45:20 EDT
This appears to be the same bug in the Gnome bugzilla:

Bug 537599 – gstfile / discover fails for ogg files with skeleton stream
http://bugzilla.gnome.org/show_bug.cgi?id=537599
Comment 5 Bastien Nocera 2008-08-20 10:37:59 EDT
There's a patch available upstream as well.
Comment 6 Bastien Nocera 2008-08-22 19:49:58 EDT
Building in rawhide. Reopen the bug if it doesn't fix the problem (although I'll probably test it as well in the morning).
Comment 7 Bastien Nocera 2008-09-07 19:42:02 EDT
Need to add gstpb-0.10.20-ogg-skeleton.patch to F-9 as well.
Comment 8 Bastien Nocera 2008-10-28 14:30:32 EDT
*** Bug 468853 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2008-10-28 15:12:44 EDT
gstreamer-plugins-base-0.10.19-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gstreamer-plugins-base-0.10.19-4.fc9
Comment 10 Fedora Update System 2008-10-30 08:56:57 EDT
gstreamer-plugins-base-0.10.19-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-base'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9303
Comment 11 Fedora Update System 2008-11-19 09:52:21 EST
gstreamer-plugins-base-0.10.19-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.