Bug 458416 - Interactive nfs install fails
Interactive nfs install fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 461117 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-07 23:46 EDT by Jerry Williams
Modified: 2008-10-06 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 15:39:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Williams 2008-08-07 23:46:56 EDT
Description of problem: When you try and install from NFS directory it fails.


Version-Release number of selected component (if applicable):
Fedora 10 Alpha, anaconda 11.4.1.24

How reproducible: Always


Steps to Reproduce:
1. PXE boot, may be able to boot from other sources.
2. Looking for installation media on CD device /dev/sr0
3. Choose a Language: English
4. Keyboard Type: us
5. Installation Method: NFS Directory
6. Configure TCP/IP: Uncheck IPv6, but doesn't seem to matter
7. Get IP address
8. NFS Setup: Enter name doesn't seem to matter and Fedora directory doesn't  matter either, can leave both blank and ok

  
Actual results: 
loader received SIGSEGV! Backtrace:
/sbin/loader(loaderSegvHandler+0xa0)[0x8060272]
[0x132400]
/sbin/loader(mountNfsImage+0x432)[0x8060272]
/sbin/loader(main+0xafb)[0x805100b]
/lib/libc.so.6(__libc_start_main+0xe5)[0x4355d5]
/sbin/loader[0x804d9f1]
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
umounting filesytems...
you may safely reboot your system



Expected results:


Additional info:
Comment 1 Chris Lumens 2008-08-08 15:39:55 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 2 Chris Lumens 2008-09-04 11:05:34 EDT
*** Bug 461117 has been marked as a duplicate of this bug. ***
Comment 3 IBM Bug Proxy 2008-09-04 11:13:12 EDT
=Comment: #0=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> - 2008-08-07 07:43 EDT
Problem description:
During the installation of Fedora 10-Alpha on power5(P510) through network boot,
NFS Installation setup failed giving a SIGSEGV and a Backtrace as shown below.

==============================================
Total HugeTLB memory allocated, 0
Welcome to Fedora for ppc

+-------------------------+ NFS Setup +-------------------------+
|                                                               |
| Please enter the server name and path to your Fedora images.  |
|                                                               |
|          NFS server name:  9.124.111.85____________           |
|          Fedora directory: S/fedora/f10Alpha/rhel/_           |
|                                                               |
|            +----+                        +------+             |
|            | OK |                        | Back |             |
|            +----+                        +------+             |
|                                                               |
|                                                               |
+---------------------------------------------------------------+

<Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

loader received SIGSEGV!  Backtrace:
/sbin/loader(loaderSegvHandler+0xa0)[0x100081e0]
[0x100364]
/sbin/loader(mountNfsImage+0x4c8)[0x100197a8]
/sbin/loader(main+0x9c4)[0x100095a4]
/lib/libc.so.6[0xf8b5ac4]
/lib/libc.so.6[0xf8b5c80]
unmounting filesystems...
============================================

Hardware Environment
Machine type (p650, x235, SF2, etc.): P510
Cpu type (Power4, Power5, IA-64, etc.): Power5
Describe any special hardware you think might be relevant to this problem:
=Comment: #8=================================================
Cijurajan Kollanoor <cijurajan@in.ibm.com> - 2008-09-04 04:55 EDT
dvd based installation is also not proceeding

=Comment: #9=================================================
This bug is against fedora10- alpha1

*** This bug has been marked as a duplicate of 458416 ***
Comment 4 IBM Bug Proxy 2008-09-30 07:31:43 EDT
(In reply to comment #16)
> Please verify this problem in F10 alpha2. Re-open this again if it is not fixed.
> Thanks!

I verified this in next release i.e F10 beta. Issue is fixed now.
Comment 5 IBM Bug Proxy 2008-10-06 10:38:25 EDT
Closing this bug now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.