Bug 45847 - XFree crash with Matrox millenium (mga1064sg)
XFree crash with Matrox millenium (mga1064sg)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-25 13:35 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 17:39:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XFree86 config file, as requested. Cash log to follow after next crash. (1.84 KB, text/plain)
2001-06-30 18:16 EDT, Paul Broadhead
no flags Details

  None (edit)
Description Need Real Name 2001-06-25 13:35:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Easily reproducible, X will crash randomly within minutes of use 
(absolutely no crashing outside of X).  I'll get random crashes during any 
attempt to resize or move a window - complete freeze up except for 
mouse).  The only items of hardware that seem to be persistant among users 
with this problem is an Adaptec 2940uw SCSI adapter and the Matrox 
Mystique (4 MB - PCI) video card.  I know this has cropped up here before 
(BUG# 27050 with the Matrox Millenium card assigned to mharris@redhat.com) 
Are there bugs in the drivers for either of these devices and has the 
issue been resolved?


How reproducible:
Always

Steps to Reproduce:
1.startx
2.resize or move window or do anything with changing the screen or window
3.
	

Actual Results:  crash - complete freeze out except for mouse

Expected Results:  no crash

Additional info:
Comment 1 Paul Broadhead 2001-06-30 13:46:50 EDT
I could have a related problem.   To check my setup, I did a completely clean
install of 7.1 on a free partition and that show the same problem.

I have a Matrox Productiva G100, on i686, and use the Gnome graphical login. 
Occasionally on system startup after a reboot, but about 1 in 5 times on logout
back to the login screen, I have a complete system freeze.  Before the freeze,
the screen clears, blinks a few times as normal, then locks with a half blank
screen, half random coloured pixels scrolling up the screen.  On reboot I
normally have major disk errors to clear up - quite a pain. 

On my main setup, I updated XFree86 to 4.1.0 and have kept up to date on the new
kernel released by Red Hat, but the problem persists.  I notice there are a
number of XFree86 updates available but when I tried to install these I get
conflicts so can't try these out.  I tried to install the updated -SVGA
component on the clean install but that had the same conflict issues.

I have tried commenting out the  Load  "dri" line on my XF86Config-4 but this
had made no difference.

If I can help track this problem down, just let me know.  This is driving me
nuts!

Paul Broadhead
Comment 2 Paul Broadhead 2001-06-30 18:16:40 EDT
Created attachment 22307 [details]
XFree86 config file, as requested.  Cash log to follow after next crash.
Comment 3 Paul Broadhead 2001-07-13 16:17:03 EDT
It looks like I've solved my problem with system freezes on logout.  I upgraded
gdm from gdm-2.0beta2-45 (that came with Red Hat 7.1), to the latest version
from ftp://ftp.gnome.org/pub/GNOME/stable/latest/redhat/i386/Base/ i.e.
gdm-2.2.2.1-1.i386.rpm .  I had to uninstall the old version first, it would not
upgrade.  Since then, I've not had a single problem.  My system was up for seven
days
(then I had to move house) and its been up a couple of days since then.

May be my problem was not related to the others.

Thanks,
Paul Broadhead
Comment 4 Mike A. Harris 2001-07-13 17:36:29 EDT
Yes, please file separate bug reports.  Adding data that might be relevant
to a report is fine, but if there is any data that is definitely not the
same, it is time to file a second separate report, and if there are different
problems, file multiple reports.  If a problem is deemed the same by us,
we can mark it as a duplicate.  We cannot however split one report with
5 bugs in it into 5 bug reports.  Never report multiple bugs in a single
report, because when one bug is fixed that is deemed to be the main bug
the report will be closed, and the others will not be tracked.  We need
to track individual bugs separately.  That is very important.

As a side note, we have gdm 2.2.3 in rawhide.  you should likely check
there first for updated packages.
Comment 5 Mike A. Harris 2001-07-13 17:39:25 EDT
If this problem only occurs with an Adaptec SCSI controller, it is almost
certainly kernel related.  Arjan, can you comment on this at all?

As always, I need log files to analyze, before and after a crash.
Please attach X logs, and a /var/log/messages that has had any private info
shrouded.
Comment 6 Mike A. Harris 2002-02-09 05:19:32 EST
Assuming you are no longer experiencing this problem now, since you
havent provided the files, so I'm closing the report.  If the problem
persists however, and you are using XFree86 4.1.0-15 which is the current
release of XFree86, and all other updates we've released as well, please
reopen the report, and provide a file attachment each of your
X server log, X config file, and /var/log/messages using the file
attachment link below.

thanks.

Note You need to log in before you can comment on or make changes to this bug.