Bug 458503 - files /etc/DIR_COLORS* have a problem entry for CAPABILITY
files /etc/DIR_COLORS* have a problem entry for CAPABILITY
Status: CLOSED DUPLICATE of bug 457342
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-08 18:59 EDT by Eric Adams
Modified: 2008-08-08 19:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-08 19:24:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Adams 2008-08-08 18:59:03 EDT
Description of problem:

The files for DIR_COLORS have a line:
  CAPABILITY 30;41      # file with capability
This entry is causing the tcsh shell to crash on startup

Version-Release number of selected component (if applicable):


How reproducible:
constant

Steps to Reproduce:
1. set user default shell to tcsh
2. log out / log in
3. create a new gnome terminal - you get an error that complains about "ca".
   There is an entry in $LS_COLORS for "ca=30;41"
4. create a new xterm - the window flashes and dies
5. edit /etc/DIR_COLORS* to remove CAPABILITY entry and repeat tests.
  
Actual results:
Shell errors or crashes

Expected results:
normal shell startup

Additional info:
this seems related to (but does not duplicate) bugs 430823 and 450508
Comment 1 Eric Adams 2008-08-08 19:24:49 EDT
This seems to be the same problem reported in bug 457342.

*** This bug has been marked as a duplicate of bug 457342 ***

Note You need to log in before you can comment on or make changes to this bug.