Bug 457342 - New color in dircolors breaks tcsh (colorls problem)
New color in dircolors breaks tcsh (colorls problem)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tcsh (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
: 456925 457397 457438 457472 457481 457634 458503 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-30 20:58 EDT by jonathan baron
Modified: 2008-09-24 20:04 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 20:04:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add new color attribute for file with capability (504 bytes, patch)
2008-07-31 08:15 EDT, Kamil Dudka
no flags Details | Diff
patch which solves this problem generally (maybe lost patch from tcsh-6.14-8 during a tcsh rebase) (444 bytes, patch)
2008-07-31 22:24 EDT, Kamil Dudka
no flags Details | Diff

  None (edit)
Description jonathan baron 2008-07-30 20:58:09 EDT
Description of problem:

I get this error message when logging in.
.cshrc is not read.
I can correct the problem by saying
source .cshrc

Version-Release number of selected component (if applicable):

Probably caused by the new version of coreutils:
coreutils-6.10-28.fc9.i386
and
coreutils-6.10-28.fc9.x86_64

How reproducible:
always


Steps to Reproduce:
1. log in
2.
3.
  
Actual results:
error, .cshrc

Expected results:
.cshrc read

Additional info:
Comment 1 jonathan baron 2008-07-30 21:52:44 EDT
This happens with bash too.  Any terminal, I would guess.

It also prevents (sometimes) execution of the su command, even after sourcing
.cshrc.

Happily I managed to fix all my computers by installing an older version of
coreutils.  So coreutils is indeed the problem.
Comment 2 Paul Black 2008-07-31 00:15:58 EDT
I get the following when opening a tcsh shell window: "Unknown colorls variable
`ca'". Downgrading coreutils also works for me.
Comment 3 Kamil Dudka 2008-07-31 05:56:59 EDT
Thanks for your report.

This is caused by adding new color attribute to ls for highlighting file 
capabilities as requested in #449985.

This issue is bug of tcsh reported as #186037 and it should be fixed. But it 
does not work for me even on rawhide, maybe #186037 should be reopened.

Adjusting of LS_COLORS variable could help.

But I can't reproduce this bug on any other shell than (t)csh. Can you attach 
any example? And if you thing that su is broken by ls colors, an example would 
be nice, too.
Comment 4 jonathan baron 2008-07-31 06:40:14 EDT
(In reply to comment #3)
> Thanks for your report.
> 
> This is caused by adding new color attribute to ls for highlighting file 
> capabilities as requested in #449985.
> 
> This issue is bug of tcsh reported as #186037 and it should be fixed. But it 
> does not work for me even on rawhide, maybe #186037 should be reopened.

I don't understand "it does not work".  What is "it"?  And does "work" mean that
you get the error or that you do not get the error?
 
> Adjusting of LS_COLORS variable could help.

I tried set LS_COLORS=null and it didn't help.

> But I can't reproduce this bug on any other shell than (t)csh. Can you attach 
> any example? And if you thing that su is broken by ls colors, an example would 
> be nice, too.

You are probably right about bash.  I wasn't really in bash when I tried it.  I
thought I was.

I don't know what you want for an example of su failing, but here is what
happens.  Note that the prompt does not change, and I cannot access files such
as /var/log/messages.

baron@bloch ~ $ su
Password: 
Unknown colorls variable `ca'.
baron@bloch ~ $ 

As I said originally, though, this does not always happen.  In particular, it
seems to happen only when I open a new terminal window.  In an old window, su
works, even though I still get this error message and .cshrc is not read until I
source it.

Is someone going to re-open the tcsh bug, or should I do it?
Comment 5 Kamil Dudka 2008-07-31 07:37:50 EDT
(In reply to comment #4)
> I don't understand "it does not work".  What is "it"?  And does "work" mean 
that
> you get the error or that you do not get the error?
Sorry for confusion. I wasn't able to start tcsh with new version of coreutils 
and default environment on F-9 and rawhide.

> I tried set LS_COLORS=null and it didn't help.
$ tcsh || echo error starting tcsh
Unknown colorls variable `ca'.
error starting tcsh
$ export LS_COLORS=
$ tcsh || echo error starting tcsh
Unknown colorls variable `ca'.
$ echo $0
tcsh

> baron@bloch ~ $ su
> Password: 
> Unknown colorls variable `ca'.
> baron@bloch ~ $ 
What does say 'whoami' command? Did you try 'su --shell=/bin/bash'?

> Is someone going to re-open the tcsh bug, or should I do it?
I am not sure, maybe went something wrong in new coreutils version. But this 
seems to be an tcsh issue since other shells work properly. 
Comment 6 Paul Black 2008-07-31 07:49:49 EDT
Worth reassigning to tcsh to get the tcsh maintainer's opinion?
Comment 7 Kamil Dudka 2008-07-31 08:15:52 EDT
Created attachment 313092 [details]
add new color attribute for file with capability
Comment 8 Kamil Dudka 2008-07-31 08:28:57 EDT
As requested in #449985 new color attribute was added to ls for file with 
capability. But new version of coreutils broke tcsh. Patch in comment #7 adds 
this attribute (ca) to tcsh.

It will be also good to improve tcsh to start, even though any color attribute 
is missing. It should be fixed by #186037 as mentioned above, but it seems not 
to work properly.
Comment 9 Kamil Dudka 2008-07-31 11:22:39 EDT
*** Bug 456925 has been marked as a duplicate of this bug. ***
Comment 10 Kamil Dudka 2008-07-31 11:27:51 EDT
*** Bug 457397 has been marked as a duplicate of this bug. ***
Comment 11 Kamil Dudka 2008-07-31 11:32:11 EDT
Since there are a lot of bugs reported changing severity to urgent.
Comment 12 Kamil Dudka 2008-07-31 14:17:07 EDT
*** Bug 457438 has been marked as a duplicate of this bug. ***
Comment 13 Joshua Rosen 2008-07-31 15:31:25 EDT
Downgrading coreutils worked for me also. BTW is there a mechanism in Yumex to
do a downgrade? I couldn't find one, I had to download the rpm and then install
using a --force switch. There needs to be a simple way to rollback updates so
that you can recover from screwups like this. 

There also needs to be some discipline among the Fedora maintainers, this isn't
the first time that they've cavalierly thrown an untested update out that broke
something fundamental. Tcsh is not some obscure application, it's absolutely
essential. I couldn't even do an su so that I could open Xemacs as root and edit
the /etc/passwd file, I had to log out and then log in as the root user in order
to fix it. 
Comment 14 Kamil Dudka 2008-07-31 15:58:32 EDT
*** Bug 457472 has been marked as a duplicate of this bug. ***
Comment 15 Kamil Dudka 2008-07-31 22:00:08 EDT
*** Bug 457481 has been marked as a duplicate of this bug. ***
Comment 16 Kamil Dudka 2008-07-31 22:24:38 EDT
Created attachment 313153 [details]
patch which solves this problem generally (maybe lost patch from tcsh-6.14-8 during a tcsh rebase)
Comment 17 Leszek Matok 2008-08-01 02:11:01 EDT
Maybe adding "colorls" to the summary would limit number of duplicates? I know I
was searching for it first and found nothing.
Comment 18 Joachim Frieben 2008-08-01 04:14:29 EDT
(In reply to comment #17)
It was nonsense to close the (preceding) original report, namely bug 456925,
as duplicate. That one had a clear summary including the key word 'colorls'.
Comment 19 Fedora Update System 2008-08-01 04:28:25 EDT
coreutils-6.10-30.fc9 has been submitted as an update for Fedora 9
Comment 20 Kamil Dudka 2008-08-01 04:35:18 EDT
New color was removed from dircolors and built as coreutils-6.10-30.fc9.
Comment 21 Stefano Bianchi 2008-08-01 09:19:13 EDT
A quick solution, without downgrading coreutils, is the following:

1. cd $HOME
2. dircolors -p > .dircolors
3. edit .dircolors commenting out the following line:
   CAPABILITY 30;41 # file with capability

After that, when you open a (t)csh session, this new config file is read and the
error is gone.

> New color was removed from dircolors and built as coreutils-6.10-30.fc9.

This update does not show up yet. When will it be released?
Comment 22 Kamil Dudka 2008-08-01 09:58:13 EDT
(In reply to comment #21)
You can download it now from
http://koji.fedoraproject.org/koji/buildinfo?buildID=58220

This is temporary link to pending update:
https://admin.fedoraproject.org/updates/F9/pending/coreutils-6.10-30.fc9
Comment 23 jonathan baron 2008-08-01 10:18:43 EDT
The new version works for me, and the solution in #21 (which also worked) is no
longer needed.  Thanks.

For others, remember that, if you use yum localupdate for this before the new
rpm is official, you have to say --nogpg.
Comment 24 Joshua Rosen 2008-08-01 16:25:47 EDT
It worked for me also.
Comment 25 Kamil Dudka 2008-08-02 03:52:23 EDT
*** Bug 457634 has been marked as a duplicate of this bug. ***
Comment 26 Joshua Rosen 2008-08-05 15:26:46 EDT
When is the fixed version of Coreutils, 6.10.30, going to be put into the updates repository? As far as I can tell the broken version, 6.10.28, is still poisoning the updates repository.
Comment 27 Fedora Update System 2008-08-07 19:49:29 EDT
coreutils-6.10-30.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Eric Adams 2008-08-08 19:24:49 EDT
*** Bug 458503 has been marked as a duplicate of this bug. ***
Comment 29 Joachim Frieben 2008-08-10 07:27:17 EDT
After a fresh install of current "rawhide", I am again confronted with the already familiar "Unknown colorls variable `ca' message. Not setting LS_COLORS in .cshrc does not help either.". Resourcing .cshrc sets the C-shell up as expected. Package information:
- coreutils-6.12-8.fc10.x86_64
- tcsh-6.15-4.fc9.x86_64
Comment 30 Kamil Dudka 2008-08-10 09:16:34 EDT
(In reply to comment #29)
coreutils-6.10-30.fc9 was built as F-9 workaround for this bug, it does not fix the tcsh bug in any way. That's why this bug is still opened. I hope it will be fixed soon in F-9 and rawhide as well.
Comment 31 Fedora Update System 2008-08-29 08:54:07 EDT
tcsh-6.15-5.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/tcsh-6.15-5.fc9
Comment 32 Fedora Update System 2008-09-10 02:44:17 EDT
tcsh-6.15-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tcsh'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7562
Comment 33 Fedora Update System 2008-09-24 20:04:01 EDT
tcsh-6.15-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.