Bug 458527 - Regression at dependency filtering causes missing requirements
Regression at dependency filtering causes missing requirements
Status: CLOSED DUPLICATE of bug 443015
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-08-09 08:29 EDT by Robert Scheck
Modified: 2008-08-11 03:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 03:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-08-09 08:29:48 EDT
Description of problem:
Today I rebuilt my unicap package with some dependency filtering scripts as it
is needed because of a plugin vs. library naming conflict. But this is not the
problem itself. And note, the package is on all branches absolutely identical, 
but the results from F8/F9 vs. Rawhide are heavily different:

Fedora Rawhide: http://koji.fedoraproject.org/koji/rpminfo?rpmID=701426
Fedora 9: http://koji.fedoraproject.org/koji/rpminfo?rpmID=701407
Fedora 8: http://koji.fedoraproject.org/koji/rpminfo?rpmID=701409

Where the hell did all the RPM package requirements in Rawhide build go to? They
are somehow just missing in the Rawhide build!

Version-Release number of selected component (if applicable):
rpm-4.5.90-0.git8461.1
unicap-0.2.23-3

How reproducible:
Everytime, see and try e.g. with my above mentioned unicap package.
  
Actual results:
Regression at dependency filtering causes missing requirements :-(

Expected results:
Working stuff as before ASAP, as it was e.g. in the past case...
Comment 1 Robert Scheck 2008-08-09 09:25:48 EDT
Looks like "%define _use_internal_dependency_generator 0" disables too much of
the dependency generating in the new rpm.org release - please fix this crap ASAP,
thanks. Removing "%define _use_internal_dependency_generator 0" shows all of the
missing dependencies, but individual filtering gets impossible then as well.
Comment 2 Panu Matilainen 2008-08-11 03:20:24 EDT

*** This bug has been marked as a duplicate of bug 443015 ***

Note You need to log in before you can comment on or make changes to this bug.