This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 458701 - Fedora 10 Alpha doesn't boot on Fujitsu-Siemens laptop with S3 Unichrome Pro
Fedora 10 Alpha doesn't boot on Fujitsu-Siemens laptop with S3 Unichrome Pro
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-08-11 13:26 EDT by Valent Turkovic
Modified: 2008-10-25 11:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 11:54:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (56.75 KB, text/plain)
2008-08-11 13:26 EDT, Valent Turkovic
no flags Details
dmesg (3.91 KB, text/plain)
2008-08-11 13:28 EDT, Valent Turkovic
no flags Details
lspci (1.38 KB, text/plain)
2008-08-11 13:28 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2008-08-11 13:26:40 EDT
Created attachment 313982 [details]
Xorg.0.log

Description of problem:
Fedora 10 Alpha doesn't boot on Fujitsu-Siemens laptop with S3 Unichrome Pro

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. Insert Fedora 10 Live CD
2. wait
3. screen flashes and doesn't show GDM login screen
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2008-08-11 13:28:02 EDT
Created attachment 313984 [details]
dmesg
Comment 2 Valent Turkovic 2008-08-11 13:28:26 EDT
Created attachment 313985 [details]
lspci
Comment 3 Srinivasa Sha S R 2008-08-12 23:23:10 EDT
This bug could be same as Bug 446489 where  X hangs on Fedora 9 when driver set to openchrome. This is due to a bug in openchrome.
Comment 4 Valent Turkovic 2008-08-13 03:42:56 EDT
Is this a hard bug to fix? What is your estimate - will this laptop boot when Fedora 10 ships?

Thank you.
Comment 5 Xavier Bachelot 2008-08-13 13:55:57 EDT
The bug is within the hardware. Currently, the modesetting for some laptop is done thru VBE calls and in this case, VBE is not doing the right thing. Upstream is working on some new panel code that is patched in current rawhide package but is not activated for your laptop's chipset. I'll try to force it enabled in a later revision, I'm just too much time-challenged at the moment, sorry about that :-(
Comment 6 Valent Turkovic 2008-08-13 16:17:38 EDT
ah, no problem, thank you for your reply and for the heads up. I'll respin Fedora and make custom spin for this laptop once this bug gets fixed. If you hear of any fix or cludge that repairs this issue please let me know.

Cheers!
Comment 7 Xavier Bachelot 2008-10-19 10:26:57 EDT
btw, did you try the workaround suggested in comment #3 ?
Try to use :
Option     "XaaNoImageWriteRect"
Comment 8 Valent Turkovic 2008-10-20 02:32:09 EDT
I'll try it one more time to confirm, but I Fedora 10 beta boots up ok.
Comment 9 Xavier Bachelot 2008-10-20 03:28:48 EDT
ah, ok, misunderstanding on my side. If openchrome starts properly, this bug should be closed. Can you please close it when you have confirmed the driver included in the beta is fine ?
Comment 10 Valent Turkovic 2008-10-25 08:31:52 EDT
It boots ok. Please close this bug.

Note You need to log in before you can comment on or make changes to this bug.