Bug 458935 - Migrating from pidgin
Migrating from pidgin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 494985
  Show dependency treegraph
 
Reported: 2008-08-13 06:33 EDT by Rahul Sundaram
Modified: 2017-03-14 10:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 555366 (view as bug list)
Environment:
Last Closed: 2017-03-14 08:18:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 579159 None None None Never
FreeDesktop.org 32902 None None None Never

  None (edit)
Description Rahul Sundaram 2008-08-13 06:33:36 EDT
Description of problem:

With Empathy now going to be part of GNOME and plans for Fedora 10 to include Empathy by default, we really would benefit from a easy way to migrate from Pidgin.  If we can provide some way to import chat logs, contacts and settings from Pidgin, that would be awesome.
Comment 1 Brian Pepple 2008-08-13 09:34:15 EDT
I believe upstream is already working on some of this, though I'm not sure if it will be done by F10.
Comment 2 Peter Gordon 2008-08-13 20:38:07 EDT
(In reply to comment #1)
> I believe upstream is already working on some of this, though I'm not sure if
> it will be done by F10.

That's my understanding, as well. 

I can imagine there are some people who simply have used Pidgin with auto-login enabled for so long that they have forgotten their own passphrases for their various IM accounts; and I'd hate for them to have to dig manually for them, though admittedly it would not be terribly difficult since they're stored in plaintext (~/.purple/accounts.xml).
Comment 3 Peter Gordon 2008-08-24 17:20:01 EDT
Should part of this transition be having telepathy-haze and friends installed by-default (e.g., marked as such in comps)?

While I love Empathy being advocated as a default client, I'd hate for people to simply disregard it for lack of "out of the box" protocol support. (And even though there is an explicit README in the empathy package for these, I can imagine that, unfortunately, most people simply won't read it.)
Comment 4 Rahul Sundaram 2008-08-24 17:29:45 EDT
Absolutely. If the decision on migrating to Empathy as the default client has been made, change the comps file to add the additional plugins by default and make sure it is documented in detail in the release notes. I am sure, some people will still miss the details but we can do our part.
Comment 5 Brian Pepple 2008-08-24 18:40:25 EDT
(In reply to comment #3)
> Should part of this transition be having telepathy-haze and friends installed
> by-default (e.g., marked as such in comps)?

Ugh, please don't.  That really defeats some of benefits of empathy IMO.
Comment 6 Peter Gordon 2008-08-24 18:45:22 EDT
(In reply to comment #5)
> (In reply to comment #3)
> > Should part of this transition be having telepathy-haze and friends installed
> > by-default (e.g., marked as such in comps)?
> 
> Ugh, please don't.  That really defeats some of benefits of empathy IMO.

Hmm. Would it be better to add this ("install telepathy-haze for AIM/etc support") as a release note then?
Comment 7 Rahul Sundaram 2008-08-24 18:49:19 EDT
Wait. Why does it defeat the benefits?
Comment 8 Brian Pepple 2008-08-24 19:02:44 EDT
(In reply to comment #6)
> (In reply to comment #5)
> > 
> > Ugh, please don't.  That really defeats some of benefits of empathy IMO.
> 
> Hmm. Would it be better to add this ("install telepathy-haze for AIM/etc
> support") as a release note then?

Truthfully, it would be best if empathy had a ui that lists the plugins available (and what they provide) from packagekit, and then allow the user to install them as needed.  Obviously, that would need quite a bit of work to do, which probably isn't reasonable in the F10 timeframe.

As you suggested it might be best to list the various telepathy connection managers, and what they provide in the release notes (though that isn't particularly user-friendly, since I wonder how many folks actually read the release notes).  But if we start manadatorily requiring connection managers to each users request for funtionality, I see us eventually having the whole tp stack being pulled in.

Truthfully, I think Empathy is still too immature,  since issues like this should be resolved before considering making it the default in the disto.  But that's just my opinion. ;)
Comment 9 Brian Pepple 2008-08-24 19:24:01 EDT
Peter, I was re-reading some of the earlier comments and I think the better solution would be to list telepathy-haze as a default in comps (like empathy) as Rahul suggested, but not requiring it in the spec file.  that way if the user doesn't want tp-haze, they can simply remove it.
Comment 10 Peter Gordon 2008-08-24 21:25:49 EDT
(In reply to comment #9)
> Peter, I was re-reading some of the earlier comments and I think the better
> solution would be to list telepathy-haze as a default in comps (like empathy)
> as Rahul suggested, but not requiring it in the spec file.  that way if the
> user doesn't want tp-haze, they can simply remove it.

That's definitely a better idea. Would it be better to add it as a requires for the empathy item, or as a new entry altogether? (And if a new item, in which category should it be?)

Thanks!
Comment 11 Matěj Cepl 2008-11-22 17:23:46 EST
(In reply to comment #8)
> As you suggested it might be best to list the various telepathy connection
> managers, and what they provide in the release notes (though that isn't
> particularly user-friendly, since I wonder how many folks actually read the
> release notes).  But if we start manadatorily requiring connection managers to
> each users request for funtionality, I see us eventually having the whole tp
> stack being pulled in.

Note also that to the best of my knowledge, telepathy-haze supports only one-to-one chat, not MUC (or its equivalent in particular protocol).
Comment 12 Brian Pepple 2008-12-11 20:36:19 EST
An importing pidgin account info option has been added to empathy-2.25.2.  I'm guessing it doesn't import over any pidgin logs, but I could be wrong since I haven't had a chance to look at the code.
Comment 13 Peter Gordon 2009-01-27 03:18:36 EST
Correct, Brian. The source code (src/empathy-import-pidgin.c and friends) currently imports only the necessary login details, not conversation logs. 

(Apologies for the slight tardiness of the reply. I completely forgot about this bug until the recent fedora-desktop-list discussion reminded me of it.)
Comment 14 Dagan McGregor 2009-08-06 06:05:43 EDT
 This seems the best place to offer comment on the default CMs installed with Empathy, since this is still open.

 The current install of Empathy as of F11, is to include telepathy-haze and all the dependancies that pulls in along with it.

 Empathy should not depend on any CMs, in it's purest form. I would like to have dependancy for telepathy-haze removed, and if MSN support is required, use telepathy-butterfly.

 It was noted that Debian Recommend gabble and salut and Suggest haze and butterfly. 
 Recommends would be helpful in Fedora, but that's another bug :) 

 I think to simplify the move to Empathy, along with future updates, changing the rpm package to use Butterfly would be much better.
Comment 15 Rahul Sundaram 2009-10-28 06:28:01 EDT
Any progress from upstream on importing Pidgin logs?  I have years of chat logs and frequently need to refer back to them. Not possible to switch to Empathy before this gets implemented.
Comment 16 Brian Pepple 2009-10-28 10:30:16 EDT
Currently I believe they are working on allowing Empathy to read pidgin logs, but not import them.  That might have changed since the last time I looked at the bug though since I haven't looked at that bug in awhile.

https://bugzilla.gnome.org/show_bug.cgi?id=579159
Comment 17 Christopher Beland 2010-01-14 10:22:09 EST
I have split the "Empathy should not depend on telepathy-haze" issue into Bug 555366.

Reading the above comments, it sounds like log import is the only remaining issue.  However, the upstream bug seems to indicate that a patch has been applied.  I don't know if that has made its way into Fedora yet or satisfies everyone's request, but it might be cleaner to track that specific issue in a new bug.
Comment 18 Brian Pepple 2011-06-28 13:26:35 EDT
I believe pidgin logs are handled now by tp-logger(1), but since I don't use pidgin I can't verify this. If someone can verify this, we can probably close this bug.

(1) https://bugs.freedesktop.org/show_bug.cgi?id=32902
Comment 20 Debarshi Ray 2017-03-14 08:18:30 EDT
These days the empathy / telepathy stack of software components ranges from very weakly maintained to unmaintained. So I think it is safe to consider this as WONTFIX.
Comment 21 Debarshi Ray 2017-03-14 10:21:38 EDT
On second thoughts, empathy already supports importing account settings from pidgin and can access logs from it. So CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.