Bug 494985 - Tracker Bug ... What stops Empathy from being a default IM client
Tracker Bug ... What stops Empathy from being a default IM client
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
: Tracking
Depends On: 458935 470368 472655 474243 502179 503901 528291 529166
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-04-08 17:55 EDT by Matěj Cepl
Modified: 2010-01-14 11:13 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-14 11:13:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 492076 None None None Never
GNOME Desktop 548712 None None None Never
GNOME Desktop 548717 None None None Never
FreeDesktop.org 16034 None None None Never

  None (edit)
Description Matěj Cepl 2009-04-08 17:55:52 EDT
Description of problem:
Comment 1 Matěj Cepl 2009-04-08 17:57:33 EDT
http://bugs.freedesktop.org/show_bug.cgi?id=20158 and http://bugs.freedesktop.org/show_bug.cgi?id=20982 (no XMPP login at all for many sites)
Comment 2 Mathieu Bridon 2009-05-21 14:33:41 EDT
I'd suggest adding this bug too:
http://bugzilla.gnome.org/show_bug.cgi?id=573407

Not sure how to add an external bug as a dependency to this one or if that's even possible however... :-/
Comment 3 Matěj Cepl 2009-05-21 15:40:26 EDT
(In reply to comment #2)
> I'd suggest adding this bug too:
> http://bugzilla.gnome.org/show_bug.cgi?id=573407
> 
> Not sure how to add an external bug as a dependency to this one or if that's
> even possible however... :-/  

Not sure ... probably if you can reproduce it with Fedora packages it can be Fedora bug as well, couldn't it?
Comment 4 Mathieu Bridon 2009-05-21 15:59:15 EDT
I've been able to reproduce it since Fedora 10, but never took the time to report it. Today, I finally did, and before I created the new bug I thought I would search if it was already known.

I found the entry on bz.g.o, not sure it has any value in duplicating it here, but I thought it would be important to be tracked for the « empathy as default » feature.

Should I open a new bug in this bz ? The bz.g.o entry has already a lot of informations and some good discussion about the issue.
Comment 5 Matěj Cepl 2009-06-03 05:56:51 EDT
Removing external dependencies from here, as there is now RHBZ bug 503901, which reflects that (and which I am going to fix soon).
Comment 6 Matěj Cepl 2009-06-03 06:09:30 EDT
Moving all tracking from https://fedoraproject.org/wiki/Features/Empathy here.
Comment 7 Matěj Cepl 2009-06-03 11:59:42 EDT
(In reply to comment #5)
> which reflects that (and which I am going to fix soon).  

I won't ... upstream patch doesn't fix it.
Comment 8 Matthias Clasen 2009-06-08 14:25:50 EDT
(removing closed upstream bugs from the list...this is a somewhat unsatisfactory way to track these)
Comment 9 Matthias Clasen 2009-06-08 14:34:00 EDT
Filed a Fedora bug against loudmouth for the xmpp login issues in comment #1
https://bugzilla.redhat.com/show_bug.cgi?id=504668
Comment 10 pankaj pandey 2009-06-13 06:32:12 EDT
Added FreeDesktop.org bug #16034.
Empathy does not support anything behind a proxy. It is pretty much useless for me (and probably many more other college and corporate users) as i'm behind a university http proxy and pidgin works well whereas empathy is useless.
IMHO, it should not be made default unless it implements proper proxy support.
Comment 11 Felipe Contreras 2009-06-19 08:46:22 EDT
Yeah, I agree, we need to add this one:
http://bugzilla.gnome.org/show_bug.cgi?id=492076
Comment 12 Adam Williamson 2009-07-17 14:03:45 EDT
Discussed at today's critical bug review meeting. Although Empathy is a feature for F12, if a feature is not ready, we don't delay the release; we drop the feature. So it's not really a release-blocking bug. Dropping from F12Blocker on that basis.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Felipe Contreras 2009-10-15 06:03:35 EDT
Why is bug #492076 not a dependency? What good is an IM client that cannot be used on a big chunk of networks?
Comment 14 Felipe Contreras 2009-10-15 06:05:28 EDT
(In reply to comment #13)
> Why is bug #492076 not a dependency? What good is an IM client that cannot be
> used on a big chunk of networks?  

Sorry, I meant the one in GNOME:
http://bugzilla.gnome.org/show_bug.cgi?id=492076
Comment 15 Adam Williamson 2009-10-15 11:53:36 EDT
because we can't depend on external bugs.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Felipe Contreras 2009-10-15 12:12:17 EDT
(In reply to comment #15)
> because we can't depend on external bugs.

So why not create an internal bug?
Comment 17 Adam Williamson 2009-10-15 12:19:59 EDT
nobody's stopping you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Brian Pepple 2009-10-15 12:31:05 EDT
(In reply to comment #16)
> So why not create an internal bug?  

There is already a link to the external bug connected to this, and all the work on implementing it is being upstream.
Comment 19 Felipe Contreras 2009-10-15 12:43:32 EDT
(In reply to comment #18)
> (In reply to comment #16)
> > So why not create an internal bug?  
> 
> There is already a link to the external bug connected to this, and all the work
> on implementing it is being upstream.  

The bug was closed as WONTFIX... there's no work upstream, they don't care as they think few people use proxies.

And the fact that distributions are not depending on this bug fixed doesn't help.
Comment 20 Felipe Contreras 2009-10-15 14:01:05 EDT
(In reply to comment #17)
> nobody's stopping you.

Ok, done: bug #529245.

I guess other bugs should be opened for other CM's and maybe MC, but I only care about XMPP, and I think that's the case for most people.
Comment 21 Matěj Cepl 2009-10-15 17:52:46 EDT
(In reply to comment #19)
> (In reply to comment #18)
> > (In reply to comment #16)
> > > So why not create an internal bug?  
> > 
> > There is already a link to the external bug connected to this, and all the work
> > on implementing it is being upstream.  
> 
> The bug was closed as WONTFIX... there's no work upstream, they don't care as
> they think few people use proxies.

No, it wasn't. It was closed as NOTOURBUG, which means that the work has moved elsewhere ... particularly if you want to shout go to these bugs at bugs.freedesktop.org http://is.gd/4lond
Comment 22 Matěj Cepl 2009-10-15 17:55:47 EDT
And BTW, just to make it clear, this is not a regression in the underlying technology, but in UI. Pidgin doesn't work with proxy either, its advantage is solely in the fact that they can be switched off per account.

And concerning connecting to jabber with HTTPS-only proxy ... use jabber server which listens on https port (e.g., see http://www.jabber.cz/wiki/Jabbim#Alternativn.C3.AD_zp.C5.AFsoby_p.C5.99ipojen.C3.AD ... soumar.jabbim.cz works on port 443).
Comment 23 Felipe Contreras 2009-10-15 18:15:40 EDT
(In reply to comment #21)
> (In reply to comment #19)
> > The bug was closed as WONTFIX... there's no work upstream, they don't care as
> > they think few people use proxies.
> 
> No, it wasn't. It was closed as NOTOURBUG, which means that the work has moved
> elsewhere ... particularly if you want to shout go to these bugs at
> bugs.freedesktop.org http://is.gd/4lond  

That's one way to look at it. The reality is that nobody is working at it.

There's no bug to get proxy support for XMPP. The closest one would be:
https://bugs.freedesktop.org/show_bug.cgi?id=23640

But that's for gabble 0.9 (wocky) which is not F12. And even then, it's not assigned, don't have priority, nor comments. I wouldn't bet it would get fixed soon.

And then who knows what other things need fixing, probably mission-control.

The link you provided is just grepping for 'proxy', most of those have nothing to do with what we are talking about here.
Comment 24 Felipe Contreras 2009-10-15 18:19:56 EDT
(In reply to comment #22)
> And BTW, just to make it clear, this is not a regression in the underlying
> technology, but in UI. Pidgin doesn't work with proxy either, its advantage is
> solely in the fact that they can be switched off per account.

Excuse me? Pidgin definitely has proxy support. That's basically the only reason I (and many other people) use it.

> And concerning connecting to jabber with HTTPS-only proxy ... use jabber server
> which listens on https port (e.g., see
> http://www.jabber.cz/wiki/Jabbim#Alternativn.C3.AD_zp.C5.AFsoby_p.C5.99ipojen.C3.AD
> ... soumar.jabbim.cz works on port 443).  

I don't know what's that about. I want to use XMPP through my company's HTTP proxy which works perfectly fine in Pidgin, and actually it was working with a few tricks on Fedora 11, but broken on Fedora 12.
Comment 25 Christopher Beland 2010-01-14 10:18:17 EST
The Fedora 12 release notes document that Empathy is now the default IM client.  Is this tracking bug still needed?
Comment 26 Brian Pepple 2010-01-14 10:47:07 EST
No, as you noted we've made it the default so this tracker bug isn't needed any longer.  Not really sure what status it should be closed as tho.
Comment 27 Christopher Beland 2010-01-14 11:13:53 EST
We'll call it CURRENTRELEASE, then.  If HTTP proxies are still broken for XMPP in Fedora 12, or there are any other outstanding issues with Empathy, it would be worth filing new bugs.

Note You need to log in before you can comment on or make changes to this bug.