Bug 459045 - Updating RHEL5.1 to RHEL5.2 gives conflicts in kmod-gfs2
Updating RHEL5.1 to RHEL5.2 gives conflicts in kmod-gfs2
Status: CLOSED DUPLICATE of bug 445591
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
5.1
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Robert Peterson
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 17:31 EDT by Forrest Taylor
Modified: 2010-01-11 22:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 17:51:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Forrest Taylor 2008-08-13 17:31:19 EDT
Description of problem:
On a cluster system that has RHEL 5.1, I tried to update to RHEL 5.2, however the `yum update` command did not complete with the following errors:

Transaction Check Error:  
file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-1.92-1.1.el5_2.2 conflicts with file from package kmod-gfs2-xen-1.52-1.16.el5

file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-1.92-1.1.el5_2.2 conflicts with file from package kmod-gfs2-1.52-1.16.el5

file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-xen-1.92-1.1.el5_2.2 conflicts with file from package kmod-gfs2-xen-1.52-1.16.el5

file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-xen-1.92-1.1.el5_2.2 conflicts with file from package kmod-gfs2-1.52-1.16.el5

I had to remove the stated packages and install the newer versions again.



Version-Release number of selected component (if applicable):
kmod-gfs2-1.52-1.16.el5 to kmod-gfs2-1.92-1.1.el5_2.2


How reproducible:
Every time.  I did the same update on nine machines and each reported these errors.

Steps to Reproduce:
1. yum update


Expected results:
I would have expected the rpm to have the ability to not cause a conflict with an older package nor with a different package.


Additional info:
Comment 1 Nate Straz 2008-08-13 17:51:56 EDT

*** This bug has been marked as a duplicate of bug 445591 ***

Note You need to log in before you can comment on or make changes to this bug.