Bug 445591 - (gfs2-kmod-upgrade) rhn based upgrade of rhel 5.1 to rhel 5.2 fails due to module conflicts
rhn based upgrade of rhel 5.1 to rhel 5.2 fails due to module conflicts
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Chris Feist
GFS Bugs
:
: 446119 453001 459045 (view as bug list)
Depends On:
Blocks: RHEL5u2_relnotes
  Show dependency treegraph
 
Reported: 2008-05-07 16:13 EDT by Robert M Williams
Modified: 2009-05-27 23:28 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
(all architectures) If your system has an older version of the gfs2-kmod package installed but the yum-kmod package is not installed, upgrading from Red Hat Enterprise Linux 5.1 to 5.2 will fail. To prevent this, install the latest version of yum-kmod first (using yum install yum-kmod) before running yum update.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 17:13:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert M Williams 2008-05-07 16:13:30 EDT
Description of problem:
rhn based upgrade of rhel 5.2 to rhel 5.2 fails due to module conflicts with
kmod-gfs2 and kmod-gfs2-xen

Version-Release number of selected component (if applicable):
yum-3.0.1-5.el5

How reproducible:
install rhel 5.1 server (Server VT Cluster ClusterStorage)

Steps to Reproduce:
1.install rhel 5.1 server (Server VT Cluster ClusterStorage)
2.configure up2date to use rhn repo
3.register system
4.run yum update
  
Actual results:
system scans for depends and downloads needed files
after accepting the gpg key transaction test begins
transaction test completes
error is displayed:

Transaction Check Error:   file /etc/depmod.d/gfs2.conf from install of
kmod-gfs2-1.92-1.1.el5 conflicts with file from package kmod-gfs2-xen-1.52-1.16.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-1.92-1.1.el5 conflicts
with file from package kmod-gfs2-1.52-1.16.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-xen-1.92-1.1.el5
conflicts with file from package kmod-gfs2-xen-1.52-1.16.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-xen-1.92-1.1.el5
conflicts with file from package kmod-gfs2-1.52-1.16.el5


Expected results:


Additional info:
Comment 2 James Laska 2008-05-07 16:31:17 EDT
What rhn server was being used for this test?  Can you list teh channels
subscribed to? (echo repo list | yum shell)?
Comment 5 James Antill 2008-05-07 16:56:17 EDT
 Actually this set of errors are coming from rpm, so there isn't anything yum
can do.
Comment 6 James Antill 2008-05-07 16:58:21 EDT
 So saying that, again typing while I think, ... yum-kmod plugin should be
"doing the right thing" here, AIUI.

 What's the output of: yum list yum\*

...and does the latest yum/yum-kmod fix it?
Comment 7 James Antill 2008-05-07 17:11:41 EDT
 Ok, so if I login to the test base and "yum install yum-kmod" and then yum
update, I get:

Installing:
 dhcpv6-client           i386       1.0.10-4.el5     rhel-i386-server-5  120 k
     replacing  dhcpv6_client.i386 0.10-33.el5

 kernel                  i686       2.6.18-92.el5    rhel-i386-server-5   14 M
 kernel-xen              i686       2.6.18-92.el5    rhel-i386-server-5   15 M
 kmod-gfs                i686       0.1.23-5.el5    
rhel-i386-server-cluster-storage-5  138 k
 kmod-gfs-xen            i686       0.1.23-5.el5    
rhel-i386-server-cluster-storage-5  138 k
 kmod-gfs2               i686       1.92-1.1.el5    
rhel-i386-server-cluster-storage-5  436 k
 kmod-gfs2-xen           i686       1.92-1.1.el5    
rhel-i386-server-cluster-storage-5  426 k
 libhugetlbfs            i386       1.2-5.el5        rhel-i386-server-5   14 k
     replacing  libhugetlbfs-lib.i386 1.0.1-1.el5
Removing:
 kmod-gfs                i686       0.1.19-7.el5     installed         304 k
 kmod-gfs-xen            i686       0.1.19-7.el5     installed         304 k
 kmod-gfs2               i686       1.52-1.16.el5    installed         1.1 M
 kmod-gfs2-xen           i686       1.52-1.16.el5    installed         1.1 M

...which I'm pretty sure is the right thing.
Comment 8 James Antill 2008-05-07 17:14:01 EDT
 And removing yum-kmod and running again, I get basically the same output except
the old versions aren't being removed.

 So the big question is, why isn't yum-kmod installed on a system with kmods
installed ... and can/does this happen to our customers?
Comment 9 James Antill 2008-05-07 17:19:56 EDT
 Note that I didn't run the Transaction ... as I didn't want to alter the
machine, from it's current state. But I'm 99%+ sure that if yum-kmod is
installed rpm won't complain.
Comment 10 Seth Vidal 2008-05-07 18:03:05 EDT
if you can reproduce it add 'test' to tsflags in yum.conf under [main]

and run the ts.

Comment 11 Chris Feist 2008-05-07 18:32:55 EDT
I added the 'test' flag and got the same errors.

I also added a repo with gfs2-kmod packages that obsoleted their respective
packages and also received the same error, although this time in the yum log I
saw this: 

 kmod-gfs2               i686       1.92-1.2.test.3.el5  gfs2-kmod         433 k
     replacing  kmod-gfs2.i686 1.52-1.16.el5

 kmod-gfs2-xen           i686       1.92-1.2.test.3.el5  gfs2-kmod         425 k
     replacing  kmod-gfs2-xen.i686 1.52-1.16.el5
Comment 14 Suzanne Yeghiayan 2008-05-12 16:51:21 EDT
*** Bug 446119 has been marked as a duplicate of this bug. ***
Comment 15 Don Domingo 2008-05-12 18:28:53 EDT
thanks Suzanne, adding to RHEL5.2 release notes updates:

<quote>
If your system has an older version of the yum-kmod and gfs2-kmod packages
installed, upgrading from Red Hat Enterprise Linux 5.1 to 5.2 will fail. To
prevent this, upgrade your yum-kmod to the latest version first (using yum
update yum-kmod) before running yum update.
</quote>

note that as per BZ#428323, the following bug also exists:

<quote>
If your system has yum-rhn-plugin-0.5.2-5.el5_1.2 (or an earlier version)
installed, you will be unable to upgrade to Red Hat Enterprise Linux 5.2 through
yum update. To work around this, upgrade your yum-rhn-plugin to the latest
version (using yum update yum-rhn-plugin) before running yum update.
</quote>

FYI. anyhow, please advise if any further revisions are required. thanks!
Comment 16 Rob Kenna 2008-05-13 09:58:22 EDT
"If your system has older versions of both the yum-kmod and gfs2-kmod packages..."


(Perhaps) slightly clearer wording.  Not a biggy.
Comment 17 Chris Feist 2008-05-13 15:17:46 EDT
Don, this issue only happens when you don't have yum-kmod installed (if yum-kmod
was installed we wouldn't have this issue).  So a possible re-wording would be:

If your system has an older version of the gfs2-kmod packages installed without
the yum-kmod package installed, upgrading...
Comment 18 Don Domingo 2008-05-13 18:42:18 EDT
thanks Chris, revising as:

<quote>
If your system has an older version of the gfs2-kmod package installed but the
yum-kmod package is not installed, upgrading from Red Hat Enterprise Linux 5.1
to 5.2 will fail. To prevent this, install the latest version of yum-kmod first
(using yum install yum-kmod) before running yum update.
</quote>

please advise if any further revisions are required. thanks!
Comment 19 Chris Feist 2008-05-13 19:05:07 EDT
That looks good to me.  Thanks!
Comment 20 Rob Kenna 2008-05-13 23:03:38 EDT
Looks good to me.
Comment 21 Chris Feist 2008-05-22 17:13:20 EDT
There should be nothing to fix for this bug other than installing yum-kmod and
once the user has the 5.2 gfs2-kmod package installed they won't have an issue
upgrading to 5.3.  Closing this as WONTFIX.
Comment 22 Chris Feist 2008-06-26 15:37:40 EDT
*** Bug 453001 has been marked as a duplicate of this bug. ***
Comment 23 Ryan Lerch 2008-08-06 22:46:16 EDT
Tracking this bug for the Red Hat Enterprise Linux 5.3 Release Notes.
Comment 24 Ryan Lerch 2008-08-06 22:46:16 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.
Comment 25 Nate Straz 2008-08-13 17:51:56 EDT
*** Bug 459045 has been marked as a duplicate of this bug. ***
Comment 26 Ryan Lerch 2008-11-04 19:45:21 EST
as per comment #31 on https://bugzilla.redhat.com/show_bug.cgi?id=248129 
i am removing this note from the 5.3 release notes.

Note You need to log in before you can comment on or make changes to this bug.