Bug 459085 - (regression) Forced to add or delete channels. Can't "do nothing". (Need to re-instate "No Change" option in SSM Channel Membership management)
(regression) Forced to add or delete channels. Can't "do nothing". (Need to r...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
511
All Linux
high Severity high
: ---
: ---
Assigned To: Jay Dobies
Corey Welton
: Triaged
: 481394 (view as bug list)
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-08-14 08:16 EDT by paul boin
Modified: 2010-10-22 23:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paul boin 2008-08-14 08:16:36 EDT
Description of problem:

Trying to add a particular channel to all currently selected machines in the 'System Set Manager'.  I think this used to present radio buttons for each channel that I could sub or un-sub for the current list.

There seems to be new checkbox functionality in 5.1.1 that doesn't give me the third 'do nothing' option for child channels that I don't want add *or* subtract.  

Version-Release number of selected component (if applicable):

5.1.1

How reproducible:

1.  Select a set of machines in System Set Manager.
2.  Click 'Manage'.
3.  Click 'Manage systems' channel memberships'.
4.  Check ( or uncheck ) any child channel.
5.  Click 'Alter subscriptions'.
6.  On the acknowledgement report, see that every channel is either being added or being deleted.  We can't 'do nothing' with all of the other channels.
  
Actual results:


Expected results:


Additional info:
Comment 1 Clifford Perry 2008-08-27 12:39:32 EDT
This change was done as part of the EUS work within Satellite 5.1.0 development to make mass subscribe/unsubscribe within SSM easier. 

Looking I do see that we lost the 'do nothing' capability for a listed child channel. For all child channels listed, we have to do something now, either subscribe all selected systems to the channel, or unsubscribe all selected systems from the child channel. We do not have a way to say, do nothing with selected systems for this specific child channel. I would like us to re-review this page to determine a way to add back in the 'do nothing' or "No Change" options which we had previously within Satellite 5.0. 

Cliff.
Comment 3 Xixi 2009-01-23 19:32:00 EST
*** Bug 481394 has been marked as a duplicate of this bug. ***
Comment 5 Jay Dobies 2009-01-26 11:29:01 EST
Ahh, this was another option I was considering for the channel (un)subscribe performance issues. We can avoid a lot of the checking to determine if a server is already subscribed if we add the ability to indicate they don't want to change the channel in the first place. I'll do this in conjunction with the performance issues.
Comment 6 Jay Dobies 2009-01-29 09:43:17 EST
Commit: 9f3e890033f154588e3d599bf462579c2e981b6d

Added "Do Nothing" option. The page now defaults to this option.
Comment 7 Corey Welton 2009-02-05 21:53:34 EST
QA Verified, user is now able to select "(*) Do nothing" and said channels will not be affected upon submit.
Comment 10 wes hayutin 2009-08-03 10:56:24 EDT
release pending.. but found
https://bugzilla.redhat.com/show_bug.cgi?id=515266
in the process
Comment 11 Brandon Perkins 2009-09-10 16:27:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.