Bug 459193 - gpk-application brings in extra packages that aren't needed, if using plain yum
gpk-application brings in extra packages that aren't needed, if using plain yum
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-14 17:21 EDT by James Antill
Modified: 2008-10-27 09:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 09:32:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-08-14 17:21:40 EDT
Description of problem:

 Add "quilt", via. search or from the programming section.
 Apply.
 gpk-application says it also needs:

Postfix Mail Transport Agent (postfix)
The Perl programming language (perl)

 "yum install quilt" doesn't need anything.

 Worth noting is that perl.x86_64 is installed (perl.i386 isn't). And exim is installed, but postfix isn't.

Version-Release number of selected component (if applicable):
gnome-packagekit.x86_64                  0.2.3-9.fc9            installed
Comment 1 Richard Hughes 2008-08-15 05:19:07 EDT
Yep, PackageKit doesn't play nice with multiarch right now. I've recently got a 64 bit machine, so I can start to debug why this would be so.
Comment 2 James Antill 2008-08-18 13:42:06 EDT
 I'm confused ... my understanding was that PK would just hand this off to yum, and then get back the transaction members. Does this mean PK is doing some depsolving itself?
Comment 3 Richard Hughes 2008-08-19 12:57:36 EDT
Yes, it's not doing "depsolve install of quilt" and then returning members, it's resolving the dependancies of quilt and trying to find a package that matches it. it's probably somehting we need to move back up to yum. Myabe you can check if the code is sane in master now?
Comment 4 James Antill 2008-08-20 12:18:52 EDT
 I'm not sure where to look :).

 However I can you that what you really need to do is "run a real install/remove transaction, and get the result". Basically as though the user did: "echo n | yum install whatever" ... anything else is almost certainly going to get different results in some cases.

 It's also worth mentioning the the depsolver will do different things depending on what is install/to-be-installed ... so say:

1. yum install something-that-needs-blah
2. yum install something-that-provides-blah something-that-needs-blah

...can act differently, if nothing that provides blah is installed (and the something you are installing isn't what yum would pull in by default).

 This goes directly to the postfix pull above, as I assume the req. there is on mta or /usr/sbin/sendmail something generic like that.
Comment 5 James Antill 2008-10-12 20:43:27 EDT
*** Bug 466690 has been marked as a duplicate of this bug. ***
Comment 6 Richard Hughes 2008-10-27 09:32:50 EDT
Right, should all be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.