Bug 459220 - port webservice function updateKeywords from BZ 2.18 to 3.2
port webservice function updateKeywords from BZ 2.18 to 3.2
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Noura El hawary
:
: 427918 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-15 00:56 EDT by Noura El hawary
Modified: 2013-06-24 00:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 23:59:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v1 for updateKeywords function (6.23 KB, patch)
2008-08-15 00:57 EDT, Noura El hawary
dkl: review+
Details | Diff

  None (edit)
Description Noura El hawary 2008-08-15 00:56:03 EDT
need to have the function updateKeywords in bugzilla 3.2

NOTE : currently the function Bug.update can do updating bug keywords.

Noura
Comment 1 Noura El hawary 2008-08-15 00:57:57 EDT
Created attachment 314373 [details]
v1 for updateKeywords function 

Patch for webservice function bugzilla.updateKeywords, this is an example of how you can call it:

$call = $rpc->call( 'bugzilla.updateKeywords', {bug_id => 406121, keywords => "Reopened", action => "delete", nomail => 1}, $username, $password );

Please Review.

Thanks,
Noura
Comment 2 David Lawrence 2008-08-15 16:12:42 EDT
Comment on attachment 314373 [details]
v1 for updateKeywords function 

Looks good Noura. Please check in.

Dave
Comment 3 David Lawrence 2008-08-18 14:09:18 EDT
*** Bug 427918 has been marked as a duplicate of this bug. ***
Comment 4 Noura El hawary 2008-08-18 23:59:49 EDT
Thanks for the review Dave.

Committed to cvs now.

Noura
Comment 5 David Lawrence 2008-08-20 17:22:59 EDT
Jiri, this will be in the next update as soon as Brew comes back online and we are allowed to push packages to the colos in PHX.

Note You need to log in before you can comment on or make changes to this bug.