Bug 459428 - rcp.imapd startup script fails
rcp.imapd startup script fails
Status: CLOSED DUPLICATE of bug 459568
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-18 15:31 EDT by Need Real Name
Modified: 2008-08-20 16:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-20 16:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-08-18 15:31:04 EDT
rcp.imapd: libnfsidmap: unable to determine a default nfsv4 domain; consider specifying one in idmapd.conf
Boot splash control client USAGE: plymouth [..]
Comment 1 Need Real Name 2008-08-18 15:43:40 EDT
This is due to eth0 being down, but it would be nice if it gracefully [FAILED] rather than showing plymouth usage information.
Comment 2 Hasan Ceylan 2008-08-19 19:17:37 EDT
Actually it is /etc/init.d/functions to blame

in functions

# Log that something failed
failure() {
  local rc=$?
  #if [ -z "${IN_INITLOG:-}" ]; then
  #   initlog $INITLOG_ARGS -n $0 -s "$1" -e 2
  #fi
  [ "$BOOTUP" != "verbose" -a -z "${LSB:-}" ] && echo_failure
  [ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --details=yes
  return $rc
}


failure function fails to check if rhgb is up and running and tries to inform rhgb to popup details console so that the user is notified of the service failing to start.

I think this is amongst the todos related to rhgb to plymouth conversion...

Right?

Hasan Ceylan
Comment 3 Steve Dickson 2008-08-20 07:50:02 EDT
I *think* you are correct... Adding Bill to the cc list to get his opinion...
Comment 4 Ray Strode [halfline] 2008-08-20 16:41:28 EDT
Nope, this is all plymouths fault (fixed in rawhide, but rawhide isn't going out)
Comment 5 Ray Strode [halfline] 2008-08-20 16:42:08 EDT

*** This bug has been marked as a duplicate of bug 459568 ***
Comment 6 Hasan Ceylan 2008-08-20 16:48:19 EDT
Good to know either way...

Thanks,
Ceylan

Note You need to log in before you can comment on or make changes to this bug.