Bug 459474 - D-Bus TypeError in posttrans
D-Bus TypeError in posttrans
Status: CLOSED DUPLICATE of bug 446282
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-19 04:19 EDT by Ed Avis
Modified: 2014-01-21 18:06 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 12:38:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2008-08-19 04:19:17 EDT
I installed Fedora 9, did 'yum update' to get new packages then 'yum install xemacs'.  It installed xemacs but gave a dbus error message.  The full output is below.

[root@bad ~]# yum install xemacs
Loaded plugins: refresh-packagekit
fedora                                                                                                                                                                        | 2.4 kB     00:00     
updates                                                                                                                                                                       | 2.3 kB     00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package xemacs.x86_64 0:21.5.28-6.fc9 set to be updated
--> Processing Dependency: xorg-x11-fonts-ISO8859-1-75dpi for package: xemacs
--> Processing Dependency: xemacs-common = 21.5.28-6.fc9 for package: xemacs
--> Processing Dependency: libcompface.so.1()(64bit) for package: xemacs
--> Processing Dependency: xemacs-packages-base >= 20060510 for package: xemacs
--> Processing Dependency: libneXtaw.so.0()(64bit) for package: xemacs
--> Running transaction check
---> Package xemacs-common.x86_64 0:21.5.28-6.fc9 set to be updated
---> Package compface.x86_64 0:1.5.2-7 set to be updated
---> Package xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.2-6.fc9 set to be updated
---> Package xemacs-packages-base.noarch 0:20070427-1.fc8 set to be updated
---> Package neXtaw.x86_64 0:0.15.1-12.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 xemacs                  x86_64     21.5.28-6.fc9    fedora            2.7 M
Installing for dependencies:
 compface                x86_64     1.5.2-7          fedora             22 k
 neXtaw                  x86_64     0.15.1-12.fc9    fedora            208 k
 xemacs-common           x86_64     21.5.28-6.fc9    fedora            5.2 M
 xemacs-packages-base    noarch     20070427-1.fc8   fedora            810 k
 xorg-x11-fonts-ISO8859-1-75dpi  noarch     7.2-6.fc9        fedora            928 k

Transaction Summary
=============================================================================
Install      6 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 9.9 M
Is this ok [y/N]: y
Downloading Packages:
(1/6): compface-1.5.2-7.x86_64.rpm                                                                                                                                            |  22 kB     00:00     
(2/6): neXtaw-0.15.1-12.fc9.x86_64.rpm                                                                                                                                        | 208 kB     00:00     
(3/6): xemacs-packages-base-20070427-1.fc8.noarch.rpm                                                                                                                         | 810 kB     00:03     
(4/6): xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch.rpm                                                                                                                    | 928 kB     00:04     
(5/6): xemacs-21.5.28-6.fc9.x86_64.rpm                                                                                                                                        | 2.7 MB     00:13     
(6/6): xemacs-common-21.5.28-6.fc9.x86_64.rpm                                                                                                                                 | 5.2 MB     00:26     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : neXtaw                                            [1/6] 
  Installing     : compface                                          [2/6] 
  Installing     : xorg-x11-fonts-ISO8859-1-75dpi                    [3/6] 
  Installing     : xemacs-common                                     [4/6] 
  Installing     : xemacs                                            [5/6] 
  Installing     : xemacs-packages-base                              [6/6] 
ERROR:dbus.connection:Unable to set arguments ('posttrans',) according to signature '': <type 'exceptions.TypeError'>: Fewer items found in D-Bus signature than in Python arguments
Unable to send message to PackageKit

Installed: xemacs.x86_64 0:21.5.28-6.fc9
Dependency Installed: compface.x86_64 0:1.5.2-7 neXtaw.x86_64 0:0.15.1-12.fc9 xemacs-common.x86_64 0:21.5.28-6.fc9 xemacs-packages-base.noarch 0:20070427-1.fc8 xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.2-6.fc9
Complete!
Comment 1 Tim Lauridsen 2008-08-19 05:07:38 EDT
This is an issue with the package kit plugin yum-packagekit, reasigning to PackageKit. It might been fixed in the latest release.
Comment 2 Richard Hughes 2008-08-19 12:38:43 EDT

*** This bug has been marked as a duplicate of bug 446282 ***

Note You need to log in before you can comment on or make changes to this bug.