Bug 459603 - g-s-d intermittantly starts/runs after login
g-s-d intermittantly starts/runs after login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 09:47 EDT by Tom London
Modified: 2008-09-05 23:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-05 23:09:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
~/.xsession-errors on startup where g-s-d was not running (73.21 KB, text/plain)
2008-08-20 09:47 EDT, Tom London
no flags Details
~/.xsession-errors from session where g-s-d was not running ..... (63.03 KB, text/plain)
2008-09-04 10:37 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2008-08-20 09:47:48 EDT
Created attachment 314629 [details]
~/.xsession-errors on startup where g-s-d was not running

Description of problem:
I'm noticing that g-s-d is only running about 1 every 2 or 3 gnome logins.

[tbl@localhost ~]$ ps agx | grep settings
 2545 ?        S      0:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
 3683 pts/0    S+     0:00 grep settings
[tbl@localhost ~]$ /usr/libexec/gnome-settings-daemon
[tbl@localhost ~]$ 

Afterwards:

[tbl@localhost ~]$ ps agx | grep settings
 2545 ?        S      0:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
 3694 ?        Ssl    0:01 /usr/libexec/gnome-settings-daemon
 5291 pts/1    S+     0:00 grep settings
[tbl@localhost ~]

That to be expected?

gnome-session-properties reports both 'gnome settings daemon' and 'gnome settings daemon helper' checked.

I attach ~/.xsession-errors below.

Version-Release number of selected component (if applicable):
gnome-settings-daemon-2.23.6-1.fc10.i386

How reproducible:
Yup.  About every other login

Steps to Reproduce:
1. gnome login
2. "ps agx | grep settings" in terminial session
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bastien Nocera 2008-08-20 09:58:18 EDT
Most likely a gnome-session bug, unless gnome-settings-daemon is crashing.

From the logs, it looks like it's being run multiple times:
** (gnome-session:3152): DEBUG: GsmAutostartApp: starting gnome-settings-daemon.desktop: command=/usr/libexec/gnome-settings-daemon startup-id=10f1d9751878bd192c12192380942658100000031520028
<snip>
** (gnome-session:3152): DEBUG: GsmAutostartApp: starting gnome-settings-daemon.desktop: command=/usr/libexec/gnome-settings-daemon startup-id=10f1d9751878bd192c121923809238275100000031520000
Comment 2 Tom London 2008-09-04 10:16:58 EDT
I'm still noticing this with latest rawhide.

'ps agx | grep settings' shows:
[tbl@tlondon ~]$ ps agx | grep settings
 2426 ?        S      0:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
 3341 pts/0    S+     0:00 grep settings
[tbl@tlondon ~]$ 

Also see this in /var/log/audit/audit.log:

type=LOGIN msg=audit(1220536813.704:12): login pid=2881 uid=0 old auid=4294967295 new auid=500 old ses=4294967295 new ses=1
type=USER_ROLE_CHANGE msg=audit(1220536813.800:13): user pid=2881 uid=0 auid=500 ses=1 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='pam: default-context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 selected-context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023: exe="/usr/libexec/gdm-session-worker" (hostname=?, addr=?, terminal=? res=success)'
type=USER_START msg=audit(1220536813.974:14): user pid=2881 uid=0 auid=500 ses=1 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='op=PAM:session_open acct="tbl" exe="/usr/libexec/gdm-session-worker" (hostname=?, addr=?, terminal=:0 res=success)'
type=USER_LOGIN msg=audit(1220536813.978:15): user pid=2881 uid=0 auid=500 ses=1 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='uid=500: exe="/usr/libexec/gdm-session-worker" (hostname=, addr=?, terminal=/dev/tty7 res=success)'
type=ANOM_ABEND msg=audit(1220536822.389:16): auid=500 uid=500 gid=500 ses=1 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=3048 comm="gnome-settings-" sig=6

Sig 6 is SIGABRT, right?

Manually starting g-s-d from console window works:

[tbl@tlondon ~]$ /usr/libexec/gnome-settings-daemon
[tbl@tlondon ~]$ 
[tbl@tlondon ~]$ ps agx | grep settings
 2426 ?        S      0:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
 3349 ?        Ssl    0:00 /usr/libexec/gnome-settings-daemon
 4338 pts/1    S+     0:00 grep settings
[tbl@tlondon ~]$
Comment 3 jmccann 2008-09-04 10:29:26 EDT
Can you please attach your .xsession-errors when running on rawhide?  (we've added a bit more information since the one you posted)  Thanks.
Comment 4 Tom London 2008-09-04 10:37:24 EDT
Created attachment 315759 [details]
~/.xsession-errors from session where g-s-d was not running .....

Here is .xsession-errors from my current session (the one I posted about above).

I logged in, did the 'ps algx | grep', immediately following by '/usr/libexec....' to start g-s-d.
Comment 5 Tom London 2008-09-04 10:40:43 EDT
Above is for:
[tbl@tlondon ~]$ rpm -q gnome-session gnome-settings-daemon
gnome-session-2.23.91-1.fc10.i386
gnome-settings-daemon-2.23.91-1.fc10.i386
[tbl@tlondon ~]$ 

Yum just told me about newer g-s-d package (2.23.91-3.fc10).

I'll update, and post any .xsession-errors I get with a failure (or report that it is working.....;) ).
Comment 6 Tom London 2008-09-04 14:30:39 EDT
This a dup of https://bugzilla.redhat.com/show_bug.cgi?id=461152 ?
Comment 7 Matthias Clasen 2008-09-04 17:02:04 EDT
Possible. Can you see if your problem goes away with gnome-desktop 2.23.91-4 ?
Comment 8 jmccann 2008-09-04 17:10:56 EDT
From that last .xsession-errors log we see that gnome-settings-daemon is starting correctly (exit status 0) with respect to gnome-session.  This is probably because it is daemonizing before we get any non-zero exit status.  We should probably not daemonize it by default.
Comment 9 Tom London 2008-09-04 17:14:13 EDT
(In reply to comment #7)
> Possible. Can you see if your problem goes away with gnome-desktop 2.23.91-4 ?

I installed.  First couple of logins afterwards were good.....

Clearly not a definitive test, since it "worked" sometimes before.....
Comment 10 Tom London 2008-09-05 09:44:57 EDT
Problem seems fixed with gnome-desktop 2.23.91-4.....
Comment 11 Matthias Clasen 2008-09-05 23:09:48 EDT
Ok, lets go with that for now.

Note You need to log in before you can comment on or make changes to this bug.