Bug 459672 - random Name or service not known errors in yum
random Name or service not known errors in yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-20 21:27 EDT by Tom Horsley
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 10:28:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-08-20 21:27:30 EDT
Description of problem:

Running yum on fedora 10 alpha, I frequently see problems like this
which go away when I immediately re-run the same command (but sometimes
reappear with a different url as this example shows):

[root@zooty ~]# yum install vlc
Loaded plugins: downloadonly, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=x86_64 error was
[Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Error: Cannot find a valid baseurl for repo: rawhide
[root@zooty ~]# yum install vlc
Loaded plugins: downloadonly, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * livna-development: livna.cat.pdx.edu
 * rawhide: mirror.umoss.org
livna-development                                        | 2.1 kB     00:00     
primary.sqlite.bz2                                       | 158 kB     00:01     
adobe-linux-i386                                         |  951 B     00:00     
http://linuxdownload.adobe.com/linux/i386/repodata/primary.xml.gz: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
http://linuxdownload.adobe.com/linux/i386/repodata/primary.xml.gz: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>
Trying other mirror.
Error: failure: repodata/primary.xml.gz from adobe-linux-i386: [Errno 256] No more mirrors to try.

Naturally, this isn't necessarily a yum error, could be in lots of places,
but I report it against yum as a place to start since that is where I've
been seeing it.

Version-Release number of selected component (if applicable):

yum-3.2.18-1.fc10

How reproducible:

Random, but frequent. If I run the command enough times, it
eventually works (and often even works the first time).

Steps to Reproduce:
1. run yum update or install
2. either get errors or don't
3.
  
Actual results:

see above

Expected results:

a smoother running process would be nice

Additional info:

I'm not seeing any failures on web pages, but I do sort of get the
impression that it takes firefox longer to access pages than I see
on my other fedora partitions, so I suppose it could even be a network
problem that is masked by firefox doing retrys automatically.

My network interface is built in to the motherboard:

Nvidia corp CK804.
Comment 1 Tom Horsley 2008-08-20 21:30:15 EDT
I should also add that I'm in the middle of restoring several
different fedora boot partitions from scratch (since my system disk
died). Aside from fedora 10 alpha (x86_64), I also have both 32
and 64 bit fedora 8 and 9 partitions.

I have been running yum extensively as a consequence of the reinstall,
and I've only seen this error when booted into fedora 10 alpha.
Comment 2 James Antill 2008-08-21 10:28:19 EDT
 This error just means "we looked up the IP address for the host, and failed to get an answer".
 I'm guessing your local recursive DNS isn't setup/working correctly, or maybe some kind of network problem?
Comment 3 Tom Horsley 2008-08-21 12:24:10 EDT
I'm guessing a network problem too, but a network problem that only happens
on fedora 10 alpha with the exact same hardware and DNS servers in resolv.conf
as when booting fedora 8 and 9 doesn't seem like NOTABUG to me, its just that
I have no idea what component it should be reported against, so I picked yum
as a place to start because that was where I always got the bug :-).
Comment 4 James Antill 2008-08-21 13:45:29 EDT
 I CLOSED it NaB because it almost certainly isn't a bug in yum/urlgrabber.
 yum/urlgrabber isn't doing anything special here (apart from many that due to mirrors it'll be asking for DNS => ip resolution for a bunch of things quickly).
 Also atm. yum is indentical in rawhide and Fed-9.

 A much better starting point would probably be glibc, but they'll probably want more data than "yum returns can't resolve errors" ... maybe create a simple C program using getinfobyname() and use that?
 tcpdump the network?

Note You need to log in before you can comment on or make changes to this bug.