Bug 459783 - RFE: Support for Low colors in graphical console
RFE: Support for Low colors in graphical console
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
: FutureFeature
: 525299 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 06:28 EDT by Kevin Verma
Modified: 2014-01-31 19:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-31 19:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Verma 2008-08-22 06:28:22 EDT
Description of feature: 

Currently graphical console displays GuestOS is all available colors. This turns to be a productivity issue while accessing GuestOS remotely (on low bandwidth)

It looks to be desirable to configure graphical console to switch to low color modes. 

Current workaround is to configure VNC or similar remote desktop solutions and use client apps to switch to low color mode. Not suitable work around for situations where administrator is remotely located all time.
Comment 1 Cole Robinson 2009-02-15 17:08:43 EST
As far as I know, this isn't supported at the gtk-vnc level, so reassigning there. Once that is complete, it would be pretty easy for us to support it in virt-manager.
Comment 2 Daniel Berrange 2009-12-13 12:49:42 EST
Moving back to virt-manager, since this capabilities is present in gtk-vnc-0.3.10-1.fc12.i686.

*Before*  calling vnc_display_open(), you can call  vnc_display_set_depth() giving one of the constants

        VNC_DISPLAY_DEPTH_COLOR_DEFAULT = 0,
        VNC_DISPLAY_DEPTH_COLOR_FULL,
        VNC_DISPLAY_DEPTH_COLOR_MEDIUM,
        VNC_DISPLAY_DEPTH_COLOR_LOW,
        VNC_DISPLAY_DEPTH_COLOR_ULTRA_LOW


Default, uses whatever the server decides is its preferred. The other 4 correspond to forcing use of 32bpp, 16bpp, 8bpp, and 4bpp. Recommend leaving on the default setting unless explicitly needing an alternative.
Comment 3 Cole Robinson 2010-02-28 21:04:05 EST
Moving to the upstream virt-manager tracker.
Comment 4 Cole Robinson 2010-02-28 21:04:22 EST
*** Bug 525299 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2014-01-31 19:53:40 EST
Since spice exists nowadays, which has all sorts of smarts about limiting bandwidth, and which doesn't even support low color modes AFAICT.

If someone turned up tomorrow with a patch, I'd help it get in. But virt-manager devs are unlikely to ever implement this. So closing as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.