Bug 525299 - [RFE] Optional lossy encoding for VNC console
Summary: [RFE] Optional lossy encoding for VNC console
Keywords:
Status: CLOSED DUPLICATE of bug 459783
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-23 20:24 UTC by Daniel
Modified: 2010-03-16 17:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-01 02:04:22 UTC


Attachments (Terms of Use)

Description Daniel 2009-09-23 20:24:26 UTC
Description of problem:

Using virt-manager through a slow link makes it really difficult to use the VNC console of KVM/qemu guests. The problem seems to be that virt-manger doesn't attempt to use lossy encoding.
This is also true for virt-viewer.

It'd be great to have an option to reduce the quality so we can use it remotely.



Version-Release number of selected component (if applicable):
virt-manager 0.8
libvirt 0.7.0
qemu-kvm 0.10.6

How reproducible:
Always.

Steps to Reproduce:
1. connect to a remote libvirt over a slow link (~300 or 400kbps)
2. open a guest console
3. see how slow it is
  
Actual results:
Image quality is perfect, but refresh rate is so slow that it's nearly impossible to use

Expected results:
Image quality and colour depth should be reduced when we use slow links.

Additional info:
If automatic selection of the best encoding/colour depth depending on the available bandwidth would really great, we could start with some fixed preset somewhere where we could choose:

- High quality
- Medium quality
- Low quality

either on a per connection basis, or a per guest basis.

Comment 1 Cole Robinson 2010-03-01 02:04:22 UTC

*** This bug has been marked as a duplicate of bug 459783 ***


Note You need to log in before you can comment on or make changes to this bug.