Bug 459826 - fedora-packager-setup broken by wget regression
fedora-packager-setup broken by wget regression
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 14:14 EDT by Ville Skyttä
Modified: 2009-03-19 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-19 12:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Workaround wget regression, don't fail if no previous certs exist (1.32 KB, patch)
2008-08-22 14:14 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2008-08-22 14:14:06 EDT
Created attachment 314825 [details]
Workaround wget regression, don't fail if no previous certs exist

fedora-packager-setup is currently broken on F-9 in certain configs because of a wget regression, see bug 441862 for details.

Additionally, the 0.3.1 version due to "set -e" will fail if no previous ~/.fedora-upload-ca.cert or ~/.fedora-server-ca.cert exist.

Fix for both attached (although the wget part would be better fixed by changing fedora-packager-setup use curl instead of wget because curl is required for other stuff in fedora-packager based on a couple of open bug reports).
Comment 1 Dennis Gilmore 2009-03-19 12:34:14 EDT
fedora-packager-0.3.3-1.fc9 implements fedora-packager-setup in python and uses pycurl to get the certs.

Note You need to log in before you can comment on or make changes to this bug.