Bug 460006 - Modify gnome-python2 requirement
Modify gnome-python2 requirement
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gramps (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 456122
  Show dependency treegraph
 
Reported: 2008-08-25 11:55 EDT by Matthew Barnes
Modified: 2008-12-09 06:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 06:37:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Barnes 2008-08-25 11:55:20 EDT
As of gnome-python2-2.22.1-3.fc10, the Python bindings for libgnome and libgnomeui have moved to a new subpackage named gnome-python2-gnome.

Consequently, this package _may_ need to change its gnome-python2 requirement to gnome-python2-gnome.

The reason for this change is because libgnome and libgnomeui pull in a large number of dependencies that some of the gnome-python2 subpackages -- such as gnome-python2-gnomevfs -- don't need, but subpackages must still require their parent package.  Splitting the libgnome[ui] bindings into a subpackage allows the other subpackages to avoid pulling in lots of unnecessary libgnome[ui] dependencies.  See bug #456122 for more details.
Comment 1 Russell Harrison 2008-11-21 11:13:17 EST
I've attached a patch to bug #443754 to upgrade the package from 2.2.10 to 3.0.3 which also includes changes that would resolve this bug.
Comment 2 Fedora Update System 2008-11-21 21:08:32 EST
gramps-3.0.3-0.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gramps-3.0.3-0.fc10
Comment 3 Fedora Update System 2008-11-26 01:14:20 EST
gramps-3.0.3-0.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gramps'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-10255
Comment 4 Fedora Update System 2008-12-09 06:37:20 EST
gramps-3.0.3-0.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.