Bug 460022 - Modify gnome-python2 requirement
Modify gnome-python2 requirement
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wallpapoz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On: 460105
Blocks: 456122
  Show dependency treegraph
 
Reported: 2008-08-25 11:56 EDT by Matthew Barnes
Modified: 2008-08-26 12:16 EDT (History)
0 users

See Also:
Fixed In Version: 0.4.1-6.svn87_trunk.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 12:16:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Barnes 2008-08-25 11:56:49 EDT
As of gnome-python2-2.22.1-3.fc10, the Python bindings for libgnome and libgnomeui have moved to a new subpackage named gnome-python2-gnome.

Consequently, this package _may_ need to change its gnome-python2 requirement to gnome-python2-gnome.

The reason for this change is because libgnome and libgnomeui pull in a large number of dependencies that some of the gnome-python2 subpackages -- such as gnome-python2-gnomevfs -- don't need, but subpackages must still require their parent package.  Splitting the libgnome[ui] bindings into a subpackage allows the other subpackages to avoid pulling in lots of unnecessary libgnome[ui] dependencies.  See bug #456122 for more details.
Comment 1 Mamoru TASAKA 2008-08-25 12:34:01 EDT
I would appreciate it if you would tell me what subpackages will be needed for:

   193        props = { gnome.PARAM_APP_DATADIR : os.path.abspath(".") + "/../share" }
   194        prog = gnome.program_init('wallpapoz', '1.0', properties=props)
   195        gnome.help_display("wallpapoz")
Comment 2 Mamoru TASAKA 2008-08-26 12:16:08 EDT
The dependency "Requires: gnome-python2-gnome" is added to wallpapoz.
Thank you for reporting, closing as CLOSED RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.