Bug 460105 - Missing dependency: pygobject2 and pycairo
Missing dependency: pygobject2 and pycairo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 460022
  Show dependency treegraph
 
Reported: 2008-08-26 04:14 EDT by Mamoru TASAKA
Modified: 2008-08-26 11:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-26 10:56:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-08-26 04:14:15 EDT
Description of problem:
http://koji.fedoraproject.org/koji/taskinfo?taskID=786055

After the bug report 460022 I tried to rebuild wallpapoz with adding
(Build)Requires gnome-python2-gnome but it fails with setup.py's checking code:

python -c 'import gtk.glade'
python -c 'gnome'
python -c 'import pygtk'

Even if pygtk2-libglade, gnome-python2-gnome, pygtk2' are all installed
as BuildRequires.
Why "Requires: pycairo, pygobject2' were removed from pygtk2?

Version-Release number of selected component (if applicable):
pygtk2-2.13.0-1.fc10

How reproducible:
100%

Steps to Reproduce:
1. $ yum install pygtk2 (2.13.0-1.fc10 is installed)
2. $ python -c 'import gtk'
3.
  
Actual results:
* Without pygobject2:
# python -c 'import gtk'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named gtk

* With pygobject2 but without pycairo:

# python -c 'import gtk'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 48, in <module>
    from gtk import _gtk
ImportError: No module named cairo

Expected results:
All of 3 commands above should succeed.

Additional info:
Comment 1 Matthew Barnes 2008-08-26 10:56:51 EDT
Sorry about that.  Fixed in pygtk-2.13.0-2.fc10.

I keep forgetting that RPM isn't smart enough to derive a pycairo requirement from the pycairo-devel build requirement, as it does with normal C libraries.

Please reopen if you still run into trouble.
Comment 2 Mamoru TASAKA 2008-08-26 11:12:49 EDT
Well, I know some person sometimes tried to let rpmbuild detect python related
dependency like perl, however as far as I know no person has succeeded it yet.

Thank you for the immediate fix.

Note You need to log in before you can comment on or make changes to this bug.