Bug 460258 - Allow components to have different default descriptions
Allow components to have different default descriptions
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.6
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: FutureFeature
: 706369 (view as bug list)
Depends On: 460257
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 02:57 EDT by Alexander Todorov
Modified: 2014-10-12 18:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.4-3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 07:03:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-08-27 02:57:30 EDT
Description of problem:
QA and rel-eng teams have agreed to start using a predefined template when filing comps bugs. This will improve work of both teams as all the necessary information will be provided in comment #0.


Additional info:
As I was told such functionality doesn't exist in Bugzilla ATM, see bug #460257.
Comment 1 Noura El hawary 2008-12-01 23:59:02 EST
Hi Alexander,

so looking at this bug and bug #460257 now this bug seems to be more specific to as it is specifying a component that needs a default template in the description field of the bug entry form. Can you please provide more description on what you need to be implemented, like the steps to get to the comps template and what would the template look like.

Noura
Comment 2 Alexander Todorov 2008-12-02 03:20:16 EST
Hi Noura,
bug #460257 is a generic issue request. If no particular text is specified for a component use the current one. 

For the comps case: the standard template is not helpful since comps is different and QE needs different information in the bug report. We think having all of this into a template and values filed in the first comment will significantly speed up handling of comps bugs. Here's a possible template, values are enclosed in <>

Description:
<add component foo to RHEL. This is the request to include foo in comps.xml>

Packages to be added:
<foo, foo-devel>

Comps group: 
<foo is in development-tools, foo-devel is in development-libs>

Default:
<no>

Mandatory:
<no>

Visible:
<yes>

Multi-lib:
<no>

Need to be present for arches:
<i386, x86_64>
Comment 3 David Lawrence 2008-12-02 11:45:41 EST
One problem we have is we don't know which component is selected at page render time so we would need to do one of two things.

1. Load all possible description texts per component in a javascript structure and dynamically change the text based on component selected.
2. Use AJAX to pull the proper text from the server when a component is selected.

Number 1 would be fine if we only have a few components with custom texts, but if we have 100's or even 1000's then the page becomes too large and will degrade UI performance.

Number 2 would be better as the initial page load would be small and we would only pull the text we need from the server. We would need to load a initial data structure that had a true/false value per component so that the AJAX call would not be made if a component does not have a custom text.

We would also need to filter this based on product as well as other products may not want this behaviour.

Dave
Comment 4 Alexander Todorov 2008-12-03 02:35:02 EST
AJAX + filtering by product sounds best.
Comment 5 David Lawrence 2010-01-15 12:32:02 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 6 David Lawrence 2010-08-25 17:39:56 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 7 Alexander Todorov 2010-09-03 12:08:53 EDT
This is still relevant.
Comment 8 Simon Green 2011-08-18 01:55:52 EDT
*** Bug 706369 has been marked as a duplicate of this bug. ***
Comment 9 Simon Green 2012-06-19 02:15:25 EDT
My main concern with this change is if a user has Javascript disabled, they won't see this. Additionally, if the user has already made a change to the comment box and they then change the component that has a different default text, do we wipe out their changes or not change the box?
Comment 10 Alexander Todorov 2012-06-19 04:02:32 EDT
(In reply to comment #9)
> My main concern with this change is if a user has Javascript disabled, they
> won't see this. 

If they have JavaScript disabled then the reply to comment functionality which quotes the previous comment will not work for them as well. If JavaScript is disabled use a sane default.


> Additionally, if the user has already made a change to the
> comment box and they then change the component that has a different default
> text, do we wipe out their changes or not change the box?

Don't wipe out the text but instead append new text at the bottom. How does this sound?
Comment 11 Simon Green 2012-10-10 23:43:10 EDT
(In reply to comment #0)
> Description of problem:
> QA and rel-eng teams have agreed to start using a predefined template when
> filing comps bugs. This will improve work of both teams as all the necessary
> information will be provided in comment #0.

What do you mean by comps bugs?
Comment 12 Alexander Todorov 2012-10-11 03:18:53 EDT
(In reply to comment #11)
> (In reply to comment #0)
> > Description of problem:
> > QA and rel-eng teams have agreed to start using a predefined template when
> > filing comps bugs. This will improve work of both teams as all the necessary
> > information will be provided in comment #0.
> 
> What do you mean by comps bugs?

Bugs against comps/rel-eng components

Note You need to log in before you can comment on or make changes to this bug.