Bug 460292 - Only one CPU core used with kernel 2.6.25.3-2.fc9.x86_64.xen
Only one CPU core used with kernel 2.6.25.3-2.fc9.x86_64.xen
Status: CLOSED DUPLICATE of bug 451170
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 08:44 EDT by Jan ONDREJ
Modified: 2009-12-14 15:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 10:33:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2008-08-27 08:44:21 EDT
Description of problem:
After upgrade to F9 of my DomU guest there is only one virtual processor found in this machine. I can't increase number of CPUs.

Version-Release number of selected component (if applicable):
Dom0:
kernel-xen-2.6.21.7-5.fc8
xen-3.1.2-2.fc8
Domu:
kernel-xen-2.6.25.3-2.fc9.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. boot F9 with latest updates and set "cpus = 2" or more
2. see output of: xm list

Actual results:
Name                                        ID   Mem VCPUs      State   Time(s)
Domain-0                                     0  2145     8     r-----    181.6
builder                                      7  2048     1     r-----     81.3

Expected results:
Name                                        ID   Mem VCPUs      State   Time(s)
Domain-0                                     0  2145     8     r-----    181.6
builder                                      7  2048     8     r-----     81.3
                                                      ^^^^ - 8 here is OK

Additional info:
With kernel from F8 (2.6.21.7-3.fc8xen) all CPUs are OK.

You also can try to increase number of CPUs by running:
    xm vcpu-set builder 8
without effect, no error is raised, but nothing is changed.

And also output of /proc/cpuinfo on guest contains only one processor.
Comment 1 Mark McLoughlin 2008-09-09 10:33:01 EDT
Yep, a known issue with the F9 x86_64 Xen guest support - fixed for F10, but fairly unlikely to be fixed in an F9 update

*** This bug has been marked as a duplicate of bug 451170 ***

Note You need to log in before you can comment on or make changes to this bug.