Bug 460294 - 'yum clean' doesn't work on systems with supplemental repositories defined
'yum clean' doesn't work on systems with supplemental repositories defined
Status: CLOSED DUPLICATE of bug 448012
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.2.z
All Linux
medium Severity high
: rc
: ---
Assigned To: John Matthews
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-27 08:53 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 09:54:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2008-08-27 08:53:08 EDT
Description of problem:
Bug 447402 resolved the problem where the RHN-related caches weren't getting cleaned as a result of a 'yum clean all'  Appears that the code added into yum-rhn-plugin-0.5.3-6.el5_2.6 is a little too aggressive and tries to handle cleaning for all repositories.  Net result is if a user has plugins enabled and also has local repositories defined, 'yum clean all' will result in:

Repository <blah> is listed more than once in the configuration

Version-Release number of selected component (if applicable):
0.5.3-6.el5_2.6

How reproducible:
Always

Steps to Reproduce:
1. Add local repository definition
2. 'yum list updates'
3. 'yum clean all'
Comment 1 Jay Turner 2008-08-27 08:54:59 EDT
Proposing as a blocker because this issue is a regression with respect to 5.2 (defect was introduced in the 5.2.z stream) and because the defect results in 'yum clean all' failing in the event a local repository is defined and plugins are enabled.
Comment 2 John Matthews 2008-08-27 09:54:36 EDT

*** This bug has been marked as a duplicate of bug 448012 ***

Note You need to log in before you can comment on or make changes to this bug.