Bug 460510 - small bug in specfile
small bug in specfile
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
: Patch
: 465274 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 08:24 EDT by Levente Farkas
Modified: 2008-12-12 08:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 08:51:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2008-08-28 08:24:20 EDT
hi,
in the spec file it's have to be:
%if 0%{?fedora} >= 8
in stead of
%if 0%{fedora} >= 8
and in this case is clearly compile on rhel too.
Comment 1 James Laska 2008-09-09 10:39:08 EDT
Thank you for the bug report.  Your issue appears to also be advised in the Packaging Guidelines available at https://fedoraproject.org/wiki/Packaging/DistTag#Conditionals.  For example, a recommended use is:

%if 0%{?fedora} >= 4
%endif

Changing to ASSIGNED.
Comment 2 Levente Farkas 2008-10-07 11:41:26 EDT
*** Bug 465274 has been marked as a duplicate of this bug. ***
Comment 3 Levente Farkas 2008-10-07 11:42:23 EDT
but even the latest rawhide spec file not contain this one char fix:-(
Comment 4 Bug Zapper 2008-11-25 21:53:14 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Daniel Veillard 2008-12-12 08:51:23 EST
Fixed in CVs and upstream,

  thanks for the report, sorry I didn't saw it earlier !

Daniel

Note You need to log in before you can comment on or make changes to this bug.