Bug 460651 - file:// not valid URL for extra repository
file:// not valid URL for extra repository
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 460650 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-29 10:10 EDT by David Juran
Modified: 2008-10-21 07:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 07:10:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2008-08-29 10:10:20 EDT
Description of problem:
anaconda won't accept file:// as a baseurl for a extra repository
I've been trying to create a Fedora DVD with just a few updated/added packages. So I unpacked the DVD, added a directory updates, copied my updates into there, ran "createrepo -d -g ../repodata/Fedora-9-comps.xml ." and then recreated the iso.

In my kicstart I add the following line:
repo updates --baseurl:///mnt/source/updates

But when I install from the DVD, I get a text box saying
"Unable to read package metadata" and "Cannot retrieve repository metadata(repomd.xml) for repository: updates."
When I edit the URL, I get a box "invalid repository URL" " You must provide an HTTP, HTTPS or FTP url to a repository" Presenting the same repo over http works fine.
IMHO, a file:// URL should be accepted as well.

One could work around this issue recreating the entire DVD using revisor, it just seems a bit overkill for my purpose.
And obviously, the same issue can be seen on RHEL5, anaconda-11.1.2.113-1

Version-Release number of selected component (if applicable):
anaconda-11.4.0.82-1
Comment 1 David Juran 2008-08-29 10:11:51 EDT
*** Bug 460650 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2008-10-09 11:35:12 EDT
Can you please give this a try with F10 beta and let me know if it works?  I've never tried this, but the code organization in F10 looks like it should be possible.  yum certainly does understand file:// URLs.  Whether or not you can do this most likely only depends on what your installation method is.
Comment 3 David Juran 2008-10-21 07:10:18 EDT
Indeed, this is now working with anaconda-11.4.1.40 in the F10 beta.

Note You need to log in before you can comment on or make changes to this bug.