Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 460666 - E: thread-posix.c: Assertion 'pthread_setspecific(t->key, userdata) == 0' in totem
Summary: E: thread-posix.c: Assertion 'pthread_setspecific(t->key, userdata) == 0' in...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 462218 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-08-29 15:14 UTC by Casey Dahlin
Modified: 2014-06-18 08:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-01 21:36:18 UTC
Type: ---


Attachments (Terms of Use)

Description Casey Dahlin 2008-08-29 15:14:43 UTC
I ran a totem instance from a terminal. When I closed it, I got the following message in the terminal I had started it from:

 E: thread-posix.c: Assertion 'pthread_setspecific(t->key, userdata) == 0' failed at pulsecore/thread-posix.c:194, function pa_tls_set(). Aborting.
Multiple segmentation faults occurred; can't display error dialog

Comment 1 Lennart Poettering 2008-09-09 19:28:20 UTC
Hmm, this is interesting. Could you get me a gdb bt please?

Comment 2 Lennart Poettering 2008-09-24 00:04:03 UTC
*** Bug 462218 has been marked as a duplicate of this bug. ***

Comment 3 Casey Dahlin 2008-10-19 18:12:33 UTC
I'm having trouble reproducing this. Any hints based on where in the code that assertion might be?

Comment 4 Lennart Poettering 2008-10-21 18:49:28 UTC
The assertion is in PA's pulsecore/thread-posix.c:194

However, this function should not fail unless the key is invalid. Which is a sign of some kind of memory corruption. Not good.

Comment 5 Lennart Poettering 2008-11-01 21:36:18 UTC
Fixed in pulseaudio-0.9.13-6.


Note You need to log in before you can comment on or make changes to this bug.