Bug 462218 - E: thread-posix.c: Assertion 'pthread_setspecific(t->key, userdata) == 0' failed
E: thread-posix.c: Assertion 'pthread_setspecific(t->key, userdata) == 0' failed
Status: CLOSED DUPLICATE of bug 460666
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-14 08:49 EDT by Hans de Goede
Modified: 2008-09-23 20:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 20:04:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-09-14 08:49:25 EDT
Description of problem:
When running totem from a terminal on a fully up2date rawhide system (including the latest 1.0.18rc3 of alsa-plugins), when I closed totem (afterplaying a movie with sound) I got this message:

[hans@localhost ~]$ totem
E: thread-posix.c: Assertion 'pthread_setspecific(t->key, userdata) == 0' failed at pulsecore/thread-posix.c:200, function pa_tls_set(). Aborting.
Aborted

Note that pulseaudio itself was started from the same terminal, so this message might actually have come from the pulseaudio daemon and not from totem / alsa-plugins-pulseaudio, but I think it was not from the daemon as that was still running after this.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.12-5.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-1.rc3.fc10.x86_64


How reproducible:
Not, I tried to but it only happened once.
Comment 1 Lennart Poettering 2008-09-23 20:04:03 EDT

*** This bug has been marked as a duplicate of bug 460666 ***

Note You need to log in before you can comment on or make changes to this bug.