Bug 460776 - xorg-x11-drv-i810-2.4.2-2.fc10.i386 Fails to start
xorg-x11-drv-i810-2.4.2-2.fc10.i386 Fails to start
Status: CLOSED DUPLICATE of bug 461829
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-31 14:09 EDT by Tom London
Modified: 2008-11-07 12:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 12:05:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/Xorg.0.log generated during "crash" (20.29 KB, text/plain)
2008-08-31 14:09 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2008-08-31 14:09:18 EDT
Created attachment 315448 [details]
/var/log/Xorg.0.log generated during "crash"

Description of problem:
xorg-x11-drv-i810-2.4.2-2.fc10.i386 fails to start X, just get random looking patterns on screen and a dead interface.  Had to hard reset system.

Reverting to xorg-x11-drv-i810-2.4.2-1.fc10.i386 "fixes".

System is Thinkpad X60 (Intel 945 graphics), running without xorg.conf.

Xorg.0.log attached below.

[root@tlondon ~]# grep '(EE)' Xorg.0.log
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Unable to locate/open config file
(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on back buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on depth buffer: rejected by kernel
(EE) intel(0): [drm] failure adding irq handler
[root@tlondon ~]# tail $_
(II) intel(0): Output configuration:
(II) intel(0):   Pipe A is on
(II) intel(0):   Display plane A is now enabled and connected to pipe A.
(II) intel(0):   Pipe B is on
(II) intel(0):   Display plane B is now enabled and connected to pipe B.
(II) intel(0):   Output VGA is connected to pipe A
(II) intel(0):   Output LVDS is connected to pipe B
(EE) intel(0): [drm] failure adding irq handler
(II) intel(0): [drm] removed 1 reserved context for kernel
(II) intel(0): [drm] unmapping 8192 bytes of SAREA 0xf960e000 at 0xb803a000
[root@tlondon ~]# 


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.4.2-2.fc10.i386

How reproducible:
Seems every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-09-03 10:14:02 EDT
Fixed with xorg-x11-drv-i810-2.4.2-3.fc10.i386, thanks!

[tbl@tlondon ~]$ grep '(EE)' /var/log/Xorg.0.log
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Unable to locate/open config file
(EE) intel(0): Failed to set tiling on front buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on back buffer: rejected by kernel
(EE) intel(0): Failed to set tiling on depth buffer: rejected by kernel
(EE) intel(0): [drm] failure adding irq handler
(EE) intel(0): underrun on pipe B!
(EE) intel(0): tried to update DSPARB with both planes enabled!
(EE) intel(0): underrun on pipe B!
[tbl@tlondon ~]$ 

Here is the snippet near the previous failure:

<<<<<SNIP>>>>>
(II) intel(0):   Display plane B is now enabled and connected to pipe B.
(II) intel(0):   Output VGA is connected to pipe A
(II) intel(0):   Output LVDS is connected to pipe B
(EE) intel(0): [drm] failure adding irq handler
(II) intel(0): [drm] mapped front buffer at 0xd2800000, handle = 0xd2800000
(II) intel(0): [drm] mapped back buffer at 0xd17df000, handle = 0xd17df000
(II) intel(0): [drm] mapped depth buffer at 0xd07df000, handle = 0xd07df000
(II) intel(0): [drm] mapped classic textures at 0xdd9f4000, handle = 0xdd9f4000
(II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(II) intel(0): DPMS enabled
<<<<<SNIP>>>>>

Believe the "Failed to set tiling...." messages are new.
Comment 2 MASAO TAKAHASHI 2008-09-09 03:33:01 EDT
I get a similar problem with xorg-x11-drv-i810
After I have installed xorg-x11-drv-i810-2.4.2-2, X server can not start.
Here is an error message.
"(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer
"
Environment
1. linux : linux-2.6.27-0.315
2. X server : 1.5.0
3. xorg-x11-drv-i810 : after 2.4.2-2
Comment 3 MASAO TAKAHASHI 2008-09-09 03:34:03 EDT
I add an aditional information.

CPU : pentium4 2.66GHZ
Graphics : intel 82865G
Comment 4 MASAO TAKAHASHI 2008-09-09 22:46:51 EDT
(In reply to comment #2)
> I get a similar problem with xorg-x11-drv-i810
> After I have installed xorg-x11-drv-i810-2.4.2-2, X server can not start.
> Here is an error message.
> "(EE) intel(0): Failed to pin front buffer: Cannot allocate memory
> 
> Fatal server error:
> Couldn't bind memory for BO front buffer
> "
> Environment
> 1. linux : linux-2.6.27-0.315
> 2. X server : 1.5.0
> 3. xorg-x11-drv-i810 : after 2.4.2-2
I add dmesg messages concerned with this problem as folows.
"[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty"
"[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12"
Comment 5 Matěj Cepl 2008-11-07 12:05:59 EST

*** This bug has been marked as a duplicate of bug 461829 ***

Note You need to log in before you can comment on or make changes to this bug.