Bug 461829 - Intel driver: Couldn't bind memory for BO front buffer
Intel driver: Couldn't bind memory for BO front buffer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 449491 460776 465844 466801 467554 469115 471973 (view as bug list)
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-09-10 16:53 EDT by Andrew McNabb
Modified: 2013-01-09 23:48 EST (History)
31 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 17:22:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with 2.4.2-7 and XAA (12.89 KB, text/plain)
2008-09-10 16:53 EDT, Andrew McNabb
no flags Details
Xorg.0.log with 2.4.2-7 and EXA (8.41 KB, text/plain)
2008-09-10 17:01 EDT, Andrew McNabb
no flags Details
Xorg startop log (18.64 KB, application/octet-stream)
2008-10-04 16:00 EDT, Konrad Karl
no flags Details
X org log file (66.04 KB, text/plain)
2008-10-15 07:21 EDT, Michael Young
no flags Details
Xorg.0.log (27.12 KB, text/plain)
2008-10-15 16:11 EDT, Konrad Karl
no flags Details
Xorg.0.log from Fedora-10-Snap3-i686-Live, no config file (33.69 KB, text/plain)
2008-10-25 17:39 EDT, Bob Arendt
no flags Details
graphic glitches, see comment #40 (44.92 KB, image/png)
2008-11-14 16:59 EST, Konrad Karl
no flags Details
Xorg.0.log - comment #40 (30.06 KB, text/plain)
2008-11-14 17:09 EST, Konrad Karl
no flags Details

  None (edit)
Description Andrew McNabb 2008-09-10 16:53:26 EDT
Created attachment 316355 [details]
Xorg.0.log with 2.4.2-7 and XAA

Description of problem:

X fails to start and the Xorg.0.log shows:

(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

Note that my xorg.conf is set to use XAA instead of EXA because the latter causes the computer to completely hang when X tries to start.  In dmesg, the following error appears repeatedly:

mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<4


Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-2.4.2-7

I was able to successfully use XAA with xorg-x11-drv-i810-2.4.2-1, but I have not been able to use either XAA or EXA in any version since.

Please let me know if any other output would be helpful.
Comment 1 Andrew McNabb 2008-09-10 17:01:28 EDT
Created attachment 316357 [details]
Xorg.0.log with 2.4.2-7 and EXA

I am also attaching the Xorg.0.log from xorg-x11-drv-i810-2.4.2-7 with EXA, which causes the system to completely hang.  In some runs, there were no errors in the Xorg.0.log (it just stopped), but in others, it gave more verbose output, which I am attaching.  It appears that the same messages appeared in the syslog as with XAA.
Comment 2 Matěj Cepl 2008-09-11 03:27:29 EDT
Isn't this the same bug as bug 461171, or are we talking about different machine here?
Comment 3 Andrew McNabb 2008-09-11 10:13:03 EDT
I could be mistaken, but I believe it to be a different issue.  In this case, I cannot ever get X to start, and there are errors that appear in the Xorg.0.log and in dmesg.  With 2.4.2-1, X usually worked, but I haven't been able to get it to start with 2.4.2-2 and later.  In contrast, bug 461171 is an occasional problem (20% of the time) that I noticed with 2.4.2-1, and it doesn't put any errors in the log.
Comment 4 Andrew McNabb 2008-09-19 17:31:44 EDT
I was just curious if there's any other information I should provide.  By the way, I've tried as recent rpms as xorg-x11-drv-i810-2.4.2-8.fc10.x86_64, still without any luck.  Thanks.
Comment 5 Andrew McNabb 2008-09-23 13:17:38 EDT
I noticed that there's an upstream commit which looks like it might be a fix:

http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-intel.git;a=commit;h=e2743a409a02978ca8e953dbbeeb96f61bbd5ce6
Comment 6 Konrad Karl 2008-09-23 18:45:00 EDT
I am suffering from the very same problem. The upstream git commit seems to be already present in the latest xorg (xorg-x11-drv-i810-2.4.2-8.fc10.i386)..

X startup fails all the time. 100% reliable.

(intel 82865G controller)

Just went from F8 (X OK) to todays Rawhide, fully uptodate.

Surviving with fbdev for now...

Greetings, Konrad
Comment 7 Konrad Karl 2008-10-04 16:00:21 EDT
Created attachment 319473 [details]
Xorg startop log
Comment 8 Konrad Karl 2008-10-04 16:02:08 EDT
comment #7 with todays rawhide xorg-x11-drv-i810-2.4.2-9. still at
fbdev :-(

system-config-display is unable to start as well.

what can I do to track this down? 
Konrad
Comment 9 Joachim Frieben 2008-10-14 11:09:01 EDT
X still does not start with the message "Fatal server error: Couldn't bind memory for BO front buffer" for a current Koji development system, featuring:

  kernel-2.6.27-3.fc10.i686   
  libdrm-2.4.0-0.21.fc10.i386
  xorg-x11-drv-i810-2.4.2-10.fc10.i386
  xorg-x11-server-Xorg-1.5.2-2.fc10.i386

for an integrated graphics chipset Intel Corporation 82845G/GL[Brookdale-G]/GE.
Comment 10 Andrew McNabb 2008-10-14 12:10:22 EDT
I have a hobbled-together system using xorg-x11-drv-i810-2.4.2-1.fc10.x86_64 with acceleration disabled.  Version 2.4.2-1 doesn't work with either EXA or XAA, and later versions don't work because of the "BO front buffer" error.  The machines I've tested this with are G43/G45.  Anyway, it sounds like they've made a bunch of stability improvements upstream recently, so it would be great to have a newer working driver.  Thanks in advance to whoever is working on this bug!
Comment 11 Konrad Karl 2008-10-14 17:32:30 EDT
ditto here: today's xorg-x11-drv-i810-2.4.2-10.fc10.i386 still only works with
NoAccel (BO front buffer) on intel 82865G.

I have another wierdness on this machine when logging in to the console
(run level 3): my user id is not being echoed the first time. after a
logout and again login it is echoed properly.
Comment 12 Dave Airlie 2008-10-15 01:51:28 EDT
can one of the 865G people try adding 

Option "Legacy3D" "false" 

to the xorg.conf device section?
Comment 13 Michael Young 2008-10-15 07:21:04 EDT
Created attachment 320413 [details]
X org log file

With
Option "Legacy3D" "false"
it gets further, displaying the splash login screen, sometoimes with corrupted text, and quickly freezes up. I am attaching the Xorg.0.log file just in case it is useful, but I don't think it is.
Comment 14 Konrad Karl 2008-10-15 16:11:20 EDT
Created attachment 320483 [details]
Xorg.0.log
Comment 15 Konrad Karl 2008-10-15 16:18:26 EDT
argh, forgot to type this comment into the attachments comment field...

Gets past the BO pin message but does not become useable.

The kde konsole background looked like a chess board (white/light grey)

My Xorg.0.log seems to be more complete, I was able to reboot the
machine via ssh.

In the kernel log I found the following lines:

Oct 15 21:25:04 f9beta1 kernel: [drm] Initialized drm 1.1.0 20060810
Oct 15 21:25:04 f9beta1 kernel: pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Oct 15 21:25:04 f9beta1 kernel: [drm:i915_driver_load] *ERROR* failed to enable MSI
Oct 15 21:25:04 f9beta1 kernel: [drm] Initialized i915 1.6.0 20080730 on minor 0
Oct 15 21:25:19 f9beta1 acpid: client connected from 2814[0:500]
Oct 15 21:52:46 f9beta1 kernel: konsole[3147]: segfault at 84 ip 0065057f sp bf81b120 error 4 in libkdeui.so.5.1.0[380000+360000]
Oct 15 21:52:47 f9beta1 kernel: [drm:i915_gem_idle] *ERROR* hardware wedged

what to try next? All help very much appreciated, no_accel is dog slow,
unfortunately.

Greetings,
Konrad
Comment 16 Robert Nichols 2008-10-18 12:52:26 EDT
*** Bug 467554 has been marked as a duplicate of this bug. ***
Comment 17 Matěj Cepl 2008-10-20 10:18:48 EDT
*** Bug 465844 has been marked as a duplicate of this bug. ***
Comment 18 Matthias Clasen 2008-10-24 19:06:09 EDT
Ajax, is this a blocker ? 

If it only affects intel kms and we are not enabling that by default, it might not be...
Comment 19 Joachim Frieben 2008-10-25 02:10:00 EDT
(In reply to comment #18) 
> If it only affects intel kms and we are not enabling that by default, it might
> not be...

Installing F10-Snap1-i686 on Intel 82845G/GL[Brookdale-G]/GE broke X unless option "NoAccel" was added to some xorg.conf file created after completion of the install procedure, and the bug still affects current "rawhide".
It does not seem to be a matter of kernel mode setting anyway which appears to be currently disabled for Intel graphics.
Comment 20 Andrew McNabb 2008-10-25 14:36:34 EDT
Matthias, I agree with Joachim that this seems unrelated to kernel mode setting.  It's a very serious problem that makes it completely impossible to start X.  Not that my vote counts for anything, but I think this should be a blocker.  Thanks!
Comment 21 Bob Arendt 2008-10-25 17:35:54 EDT
Still breaks on F10-Snap3-i686.  Booted to runlevel 3 and tried to start with:
  startx /usr/bin/xterm -- -logverbose 7
    (I yum installed xterm on to a live-usb stick)
The herringbone Xserver crosshatch came up, but no xterm and no mouse.
In another network login:
  xterm -display :0
and then the Xserver logs a
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
and a backtrace.  I've attached Xorg.0.log file, and tacked in the lines
from /var/log/messages.
Comment 22 Bob Arendt 2008-10-25 17:39:56 EDT
Created attachment 321531 [details]
Xorg.0.log from Fedora-10-Snap3-i686-Live, no config file

This is a Dell inspiron 7500 laptop. 
Fedora-10-Snap3-i686-Live, no Xorg config file (internal defaults)
Comment 23 Andrew McNabb 2008-10-27 12:13:26 EDT
Bob, yours looks like a separate bug.  You should probably open up a new bug report.
Comment 24 Gerwin Krist 2008-10-29 10:37:59 EDT
This nasty problem doesn't happen only with the i810 driver but also with the "intel" driver. First of all it's not only annoying you don't get a login manager but 2nd, there should be an error telling that X can't be started. So probably 2 bugs.

rawhide version: 29-10-2008
gpu: Intel Corporation 82865G Integrated Graphics Controller
Comment 25 Matěj Cepl 2008-10-29 11:22:22 EDT
(In reply to comment #24)
> This nasty problem doesn't happen only with the i810 driver but also with the
> "intel" driver. First of all it's not only annoying you don't get a login
> manager but 2nd, there should be an error telling that X can't be started. So
> probably 2 bugs.

Just for the record, at least since F9 i810 driver is just an alias for intel driver.
Comment 26 Bob Arendt 2008-10-31 00:30:02 EDT
(In reply to comment #23)
> Bob, yours looks like a separate bug.  You should probably open up a new bug
> report.

Thanks Andrew - I've created Bug 469292 , and added more detail for my case.
Comment 27 stefan 2008-11-03 11:35:35 EST
Hello,

i do not know if this helps at all but I have a HP Compaq d330 with a intel 82865G Integrated Graphics controller an I too have the same issue described in this thread.

I have tried running F10 snapshot3 i686 KDE4 live cd. The booting of the live cd fails when starting X, nor do i get a nice graphical plymouth boot.

extract from my xorg.0.log:

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-92.1.10.el5 i686 
Current Operating System: Linux localhost.localdomain 2.6.27.3-34.rc1.fc10.i686 #1 SMP Tue Oct
 21 01:39:53 EDT 2008 i686                                                                    
Build Date: 20 October 2008  10:41:26AM
Build ID: xorg-x11-server 1.5.2-8.fc10
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov  3 17:28:53 2008
(EE) Unable to locate/open config file
(II) Loader magic: 0x81f3400
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 4.1
        X.Org XInput driver : 2.1
        X.Org Server Extension : 1.1
        X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 7

......

drmGetBusid returned ''                                                                       
(II) [drm] loaded kernel module for "i915" driver.
(II) [drm] DRM interface version 1.3
(II) [drm] DRM open master succeeded.
(II) intel(0): [drm] Using the DRM lock SAREA also for drawables.
(II) intel(0): [drm] framebuffer mapped by ddx driver
(II) intel(0): [drm] added 1 reserved context for kernel
(II) intel(0): X context handle = 0x1
(II) intel(0): [drm] installed DRM signal handler
(**) intel(0): Framebuffer compression disabled
(**) intel(0): Tiling enabled
(==) intel(0): VideoRam: 131072 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(II) intel(0): Tiled allocation successful.
(II) intel(0): [drm] Registers = 0xfc400000
(II) intel(0): [drm] Initialized kernel agp heap manager, 33554432
(II) intel(0): [dri] visual configs initialized
(II) intel(0): Page Flipping disabled
(II) intel(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
(II) EXA(0): Offscreen pixmap area of 34406400 bytes
(II) EXA(0): Driver registered support for the following operations:
(II)         Solid
(II)         Copy
(II)         Composite (RENDER acceleration)
(==) intel(0): Backing store disabled
(==) intel(0): Silken mouse enabled
(II) intel(0): Initializing HW Cursor
(II) intel(0): [DRI] installation complete
(II) intel(0): xf86BindGARTMemory: bind key 0 at 0x03f2f000 (pgoffset 16175)
(II) intel(0): xf86BindGARTMemory: bind key 1 at 0x03f30000 (pgoffset 16176)
(II) intel(0): xf86BindGARTMemory: bind key 2 at 0x06000000 (pgoffset 24576)
(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

(II) intel(0): xf86UnbindGARTMemory: unbind key 0
(II) intel(0): xf86UnbindGARTMemory: unbind key 1
(II) intel(0): xf86UnbindGARTMemory: unbind key 2
Comment 28 Andrew McNabb 2008-11-05 15:50:06 EST
Do we have any hope for this working in Fedora 10?  Just hoping...

Thanks.
Comment 29 Matěj Cepl 2008-11-06 11:23:06 EST
*** Bug 469115 has been marked as a duplicate of this bug. ***
Comment 30 Jaroslav Franek 2008-11-06 12:31:40 EST
*** Bug 466801 has been marked as a duplicate of this bug. ***
Comment 31 Matěj Cepl 2008-11-07 12:05:59 EST
*** Bug 460776 has been marked as a duplicate of this bug. ***
Comment 32 Matěj Cepl 2008-11-07 12:06:16 EST
*** Bug 449491 has been marked as a duplicate of this bug. ***
Comment 33 Jesse Keating 2008-11-10 16:47:41 EST
An attempt to solve this by reverting the driver to not use the GEM system is in the works.  Please stay tuned for test packages.
Comment 34 Konrad Karl 2008-11-11 08:17:48 EST
feel free to throw test packages at us :-). very much appreciated!

(hardware is 00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) BTW)


Side note: with Option "Legacy3D" "no" the KDE splash screen is
being displayed properly but the X server is soon getting stuck in some
DRI ioctl . 

Just launching X and starting an xterm and twm goes OK, however when
moving around the xterm there is graphics garbage left behind
(mostly thin horizontal and vertical lines). The xterm (maximized)
survives a find / -print and runs at a fine speed. Then I got
adventurous and started firefox on www.orf.at. The page got mostly
displayed  but then the X server hung like above.

During boot I only get something like a progress bar in text mode
at the bottom of the screen, no nice splash image at all.

Greetings,
Konrad
Comment 35 Will Woods 2008-11-14 12:58:08 EST
The fix Jesse mentioned in comment #33 is in kernel-2.6.27.5-109.fc10. Could you please retest with that kernel (or newer) and confirm whether X starts now?

(In reply to comment #34)
> During boot I only get something like a progress bar in text mode
> at the bottom of the screen, no nice splash image at all.

That's expected. Graphical boot requires kernel modesetting. Intel modesetting drivers should appear sometime before F11.
Comment 36 Pieter Krul 2008-11-14 13:48:26 EST
This is on a Dell Inspiron 510M with Intel Corporation 82852/855GM Integrated Graphics Device. 

Experienced same error messages as in comment #27 with kernel-2.6.27.5-109.fc10. Tested with kernel-2.6.27.5-109.fc10, I can confirm the issue is gone for me and X can be started correctly.
Comment 37 Pieter Krul 2008-11-14 13:51:59 EST
In comment #36, it should read "same error messages with kernel-2.6.27.5-101.fc10"
Comment 38 Mace Moneta 2008-11-14 16:07:10 EST
With the new kernel, I still get a black screen and hang using XAA.  While EXA doesn't hang and I can login, I get screen corruption if using Compiz (or any 3D app).

Supermicro C2SEA with G45 X4500HD:

kernel-2.6.27.5-109.fc10.x86_64
xorg-x11-drv-i810-2.5.0-3.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-3.fc10.x86_64
xorg-x11-server-common-1.5.3-3.fc10.x86_64
Comment 39 Will Woods 2008-11-14 16:34:33 EST
EXA is the default, as far as I can tell. So if the default case works now, we can at least move this off the blocker list.

What error messages appear in Xorg.0.log if you're using XAA?

Screen corruption using Compiz/GL stuff is a separate bug - if it's font corruption, perhaps it's bug 471537?
Comment 40 Konrad Karl 2008-11-14 16:58:05 EST
xorg-x11-drv-i810-2.5.0-3.fc10.i386
kernel-2.6.27.5-109.fc10.i686
Intel Corporation 82865G

Server starts now even w/o xorg.conf but text display is heavily
corrupted. (KDE konsole, Firefox, etc) 
With no_accel there is no text corruption.

glxgears
[intel_init_bufmgr:592] Error initializing buffer manager.
668 frames in 5.0 seconds = 133.492 FPS

The corruption looks funny while typing: while typing the "The" at beginning
of this line the "Th" was cut about half vertically(only upper part shown) and
when I typed the "e" then the missing parts appeared.

will attach an image combined from three screen shots (KDE konqueror on www.heise.de)

Thanks for your efforts,
Konrad
Comment 41 Konrad Karl 2008-11-14 16:59:23 EST
Created attachment 323654 [details]
graphic glitches, see comment #40
Comment 42 Konrad Karl 2008-11-14 17:09:54 EST
Created attachment 323659 [details]
Xorg.0.log - comment #40

it is almost impossible to view this file in less or vi. about one third of the lines is invisible and gets visible when you move the cursor around vertically.
Comment 43 Will Woods 2008-11-14 17:22:42 EST
(In reply to comment #40)
> The corruption looks funny while typing: while typing the "The" at beginning
> of this line the "Th" was cut about half vertically(only upper part shown) and
> when I typed the "e" then the missing parts appeared.

Yes, that looks just like bug 471537. Follow up there for the graphical corruption problems.


Seems like X is starting up successfully now, and there's no mention of the original error message. Closing this bug.

Reopen *only* if X fails to start and the message "Couldn't bind memory for BO front buffer" appears in Xorg.0.log.
Comment 44 Will Woods 2008-11-18 14:45:12 EST
*** Bug 471973 has been marked as a duplicate of this bug. ***
Comment 45 Hollis Blanchard 2008-11-30 00:00:33 EST
I see this same problem with F10 release, on a Thinkpad T61 with Intel Mobile GM965/GL960 (PCI vendor/ID 8086:2a03).

EXA vs XAA doesn't matter, and neither does the suggested Legacy3D; the only workaround I've found is Option "NoAccel" "yes" in xorg.conf. Same error from dmesg:
  ...
  [drm:i915_gem_object_pin] *ERROR* Failure to bind: -12
  ...

Same error from Xorg.0.log:
  ...
  (EE) intel(0): Failed to pin front buffer: Cannot allocate memory

  Fatal server error:
  Couldn't bind memory for BO front buffer

kernel-2.6.27.5-117.fc10.x86_64
xorg-x11-drv-i810-2.5.0-3.fc10.x86_64

(Additionally there's a failure when the X server crashes that seems to disable all input, so X never exits cleanly and I can't switch to another virtual terminal. All I can do is hit the power button to cleanly reboot [i.e. the ACPI event seems to be handled properly].)

Note You need to log in before you can comment on or make changes to this bug.