Bug 460890 - Kernel hangs during boot
Kernel hangs during boot
Status: CLOSED DUPLICATE of bug 460565
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-02 08:40 EDT by James Morris
Modified: 2008-09-03 10:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 10:57:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Morris 2008-09-02 08:40:08 EDT
Description of problem:

Current rawhide kernels hang during boot on my system.  I had .284 running ok before this.


Version-Release number of selected component (if applicable):
2.6.27-0.295.rc5.git2.fc10.x86_64
and .290

How reproducible:

Always.

Here's the last of what I see via serial console:

debug: unmapping init memory ffffffff8176b000..ffffffff81a21000
Write protecting the kernel read-only data: 1444k
Mounting proc filesystem
Mounting sysfs filesystem
Creating /dev
Creating initial device nodes
plymouthd used greatest stack depth: 4736 bytes left
modprobe used greatest stack depth: 4464 bytes left
[drm] Initialized drm 1.1.0 20060810
ACPI: PCI Interrupt Link [LNK1] enabled at IRQ 19
pci 0000:01:08.0: PCI INT A -> Link[LNK1] -> GSI 19 (level, low) -> IRQ 19
[drm] Initialized radeon 1.29.0 20080528 on minor 0

Normally, I don't see any "drm"'s in the console log.

lspci output on a an older upstream kernel:

00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a4)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev f1)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a4)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev f2)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h [Opteron, Athlon64, Sempron] Link Control
01:08.0 VGA compatible controller: ATI Technologies Inc ES1000 (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5722 Gigabit Ethernet PCI Express
Comment 1 James Morris 2008-09-02 21:29:43 EDT
Any use of console= at the kernel command line causes this hang.

With upstream kernels, the boot seems to hang in udev, with:

"Creating initial device nodes"  as the last message seen on a serial console.
Comment 2 James Morris 2008-09-02 21:47:47 EDT
I've verified that this is happening on kernels all the way back to 2.6.26 upstream, with no module support and minimal config.  This seems to be something related to udev or other startup component.
Comment 3 James Morris 2008-09-02 22:51:52 EDT
I also tried reverting udev and plymouth a few versions back each with no success.

Can anyone else reproduce a boot hang with console=tty0 (for example) ?
Comment 4 James Morris 2008-09-03 10:57:46 EDT

*** This bug has been marked as a duplicate of bug 460565 ***

Note You need to log in before you can comment on or make changes to this bug.