Bug 460565 - plymouth gets confused by an additional serial console
plymouth gets confused by an additional serial console
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
: 460890 461601 462475 470569 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-28 13:07 EDT by Yanko Kaneti
Modified: 2008-11-10 15:30 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-10 15:16:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2008-08-28 13:07:58 EDT
Description of problem:

boot with a kernel commandline suitable for serial debugging e.g containing
console=ttyS0,115200 console=tty0
observe plymouth --show-splash from the initrd stop and do nothing, just echoing typed characters to the console. Ctrl-Alt-Del to reboot.

Version-Release number of selected component (if applicable):
plymouth-0.6.0-0.2008.08.27.2.fc10
Comment 1 Ray Strode [halfline] 2008-08-28 13:28:16 EDT
ah, I thought I stamped out the serial console bugs.  I'll take a look.
Comment 2 James Morris 2008-09-03 10:57:46 EDT
*** Bug 460890 has been marked as a duplicate of this bug. ***
Comment 3 Ray Strode [halfline] 2008-09-05 15:35:25 EDT
I think this should work a lot better in 

plymouth-0.5.0-0.2008.09.05.2.fc10

I'm going to close this bug, but if you still have problems please reopen it.

I don't normally use a serial console so there may be other plymouth integration issues lurking.
Comment 4 Yanko Kaneti 2008-09-06 15:07:27 EDT
Still some issues when started with the usual  console=ttyS0,115200 console=tty0
- if the serial console is not connected it just sits there waiting, with some errors about ttyS0 (don't have the log right now). Whenever the console is attached the boot process continues
- with console attached it sends all init messages there and nothing on tty0, thats not what I figure should happend if I am reading Documentation/serial-console.txt correctly. Expect the messages on both consoles.
Comment 5 James Morris 2008-09-07 22:27:53 EDT
Still not working for me with 
plymouth-0.6.0-0.2008.08.27.2.fc10.x86_64

The boot hangs after
"plymouthd used greatest stack depth: 4736 bytes left"
Comment 6 James Morris 2008-09-07 22:28:59 EDT
(In reply to comment #5)
> Still not working for me with 
> plymouth-0.6.0-0.2008.08.27.2.fc10.x86_64
> 
> The boot hangs after
> "plymouthd used greatest stack depth: 4736 bytes left"

Btw, this is with a normal single console=ttyS0,115200 and a connected device.

And I need this to be able to work effectively.
Comment 7 Yanko Kaneti 2008-09-08 10:30:12 EDT
with plymouth-0.6.0-0.2008.09.05.4 here it seems like back to square one, the symptoms are the same as in my original filing, regardless of the console being connected or not.

A single console=ttyS0,115200 works as expected.
Comment 8 Jeff Layton 2008-09-09 10:28:33 EDT
*** Bug 461601 has been marked as a duplicate of this bug. ***
Comment 9 Jeff Layton 2008-09-09 10:34:47 EDT
Yanko pointed me at this bug after I opened bug 461601. I had been having trouble with new kernels since the -287 series. I assumed that it was a kernel problem, but now I think that plymouthd might have been the culprit. 

I did a yum update this morning and got a plymouth update + a new kernel (and yum did install them in that order, according to the logs). The new kernel would not boot, hanging soon after the "plymouthd used greatest stack depth" warning. I ended up uninstalling plymouth packages and reinstalling them (via yum remove and yum install), and then regenerating the initrd for the kernel. Now the kernel boots successfully.

As to why uninstalling and reinstalling plymouth would matter, I'm not sure.
Comment 10 Ray Strode [halfline] 2008-09-09 11:43:55 EDT
you probably went from

plymouth-0.6.0-0.2008.08.27.2

to

plymouth-0.6.0-0.2008.09.05.4

which fixed a buggy loop
Comment 11 Jeff Layton 2008-09-09 12:18:21 EDT
Looks like the previous version of plymouth was:

Aug 29 07:12:15 Updated: plymouth-0.6.0-0.2008.08.27.2.fc10.x86_64

But I'm not sure that that explains what I saw. Here's a snippet from my yum log this morning. plymouth is updated to the new version:

Sep 09 07:24:35 Updated: libXft-devel-2.1.13-1.fc10.x86_64
Sep 09 07:24:37 Updated: plymouth-libs-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 07:24:38 Updated: plymouth-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 07:24:39 Updated: plymouth-plugin-spinfinity-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 07:24:39 Updated: plymouth-plugin-label-0.6.0-0.2008.09.05.3.fc10.x86_64

...new kernel is installed and rpm is updated. At this point -314 would hang at boot time. 

Sep 09 07:26:00 Installed: kernel-2.6.27-0.314.rc5.git9.fc10.x86_64
Sep 09 07:26:00 Updated: rpm-4.5.90-0.git8461.5.x86_64

...after I read Yanko's comments, I tried removing plymouth (thinking it might be an optional component):

Sep 09 09:59:24 Erased: mkinitrd
Sep 09 09:59:24 Erased: plymouth-plugin-spinfinity
Sep 09 09:59:26 Erased: plymouth
Sep 09 09:59:26 Erased: plymouth-plugin-label
Sep 09 09:59:27 Erased: plymouth-libs

...plymouth is removed. But looks like mkinitrd depends on it, so I reinstalled it:

Sep 09 10:00:16 Installed: mkinitrd-6.0.62-1.fc10.x86_64
Sep 09 10:00:16 Installed: plymouth-libs-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 10:00:17 Installed: plymouth-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 10:00:18 Installed: plymouth-plugin-spinfinity-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 10:00:19 Installed: plymouth-plugin-label-0.6.0-0.2008.09.05.3.fc10.x86_64

After this, I tried rebuilding the initrd and was able to successfully boot.

It seems like a yum update of the plymouth package wasn't sufficient to fix whatever the problem was, but uninstalling the package(s) completely and then reinstalling was.
Comment 12 Ray Strode [halfline] 2008-09-09 13:04:11 EDT
Interesting.  There may be something wonky going on there.

I've cloned this bug as bug 461641 to track that issue separately.
Comment 13 John Poelstra 2008-09-19 15:01:16 EDT
*** Bug 462475 has been marked as a duplicate of this bug. ***
Comment 14 Ray Strode [halfline] 2008-10-08 15:09:46 EDT
So I pushed a plymouth build plymouth-0.6.0-0.2008.10.08.1.fc10 a few minutes ago that has been confirmed to fix things for Yanko.  

It hasn't been tested in set ups with encrypted devices yet, so that may still need some work.

Leaving open until I get a test envrionment set up for that.
Comment 15 Ray Strode [halfline] 2008-11-10 15:16:00 EST
This got tested by jlaska and it seems to work (sans a mkinitrd bug)
Comment 16 Ray Strode [halfline] 2008-11-10 15:30:33 EST
*** Bug 470569 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.