Bug 460988 - Need dynamic link to libcurl of npviewer.bin arch
Need dynamic link to libcurl of npviewer.bin arch
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 462573
  Show dependency treegraph
 
Reported: 2008-09-03 02:45 EDT by Warren Togami
Modified: 2008-10-20 03:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 03:20:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2008-09-03 02:45:04 EDT
This is just a reminder: 
npviewer.bin in the future will need a dynamic link to libcurl of its own arch.  While npviewer.bin itself might not actually use any symbols in libcurl, certain plugins will have the expectation that they be there or they will simply crash.

We will need this in F-8+ and RHEL5+ nspluginwrapper.
Comment 1 Warren Togami 2008-09-03 02:48:56 EDT
NOTE: Adding this actually creates no difference to the installed system since users would already have it installed for other reasons.  This just guarantees that it will work instead of leaving it up to chance.
Comment 2 Ville Skyttä 2008-09-17 13:08:36 EDT
If it's really needed, so be it, but the assumption in comment 1 does not always hold.  The only "other reason" I have libcurl.i386 and its dependency chain installed on my x86_64 box is nspluginwrapper.i386, or more specifically, nppviewer in it.  See bug 456111 for more info.
Comment 3 Warren Togami 2008-10-03 17:51:13 EDT
nspluginwrapper-1.1.0-6 did this in the wrong way.  Requires: libcurl will not guarantee that you have the corresponding arch to match both archs of nspluginwrapper.  This needs a multilib compatible requirement on libcurl.so.4 or libcurl.so.4()(64bit).  I suspect this can be achieved either with a dynamic link to libcurl.so.4 from npviewer.bin, or perhaps with ugly hard coded Requires in the nspluginwrapper package.  Requiring libcurl package by name does not work.

I'm removing this from -8 (which also reverts the breakage of -7).
Comment 4 Warren Togami 2008-10-03 18:00:40 EDT
/usr/lib/nspluginwrapper/npplayer
        libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00320000)

Interesting, it turns out that nspluginwrapper already does pull in libcurl of its own arch from this binary.

Is this an accident?  Perhaps we should add a dynamic link to libcurl from npviewer.bin explicitly just to be sure it wont disappear sometime in the future.
Comment 5 Ville Skyttä 2008-10-05 11:46:10 EDT
See comment 2 and bug 456111.

If you want to add the explicit libcurl dependency anyway, specifying it as "Requires: libcurl%{?_isa}" would ensure correct arch in F-10+ (and would not hurt earlier distro versions, but wouldn't help them either).
Comment 6 Martin Stransky 2008-10-20 03:20:17 EDT
Honestly it's a problem in flash - firefox and other browsers don't require libcurl so i don't see any reason why nspluginwrapper should demand it just for the one broken plugin. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.