Bug 462573 - Need dynamic link to libcurl of npviewer.bin arch
Need dynamic link to libcurl of npviewer.bin arch
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nspluginwrapper (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Stransky
:
Depends On: 460988
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-17 03:28 EDT by Martin Stransky
Modified: 2008-10-20 03:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 03:20:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Stransky 2008-09-17 03:28:44 EDT
+++ This bug was initially created as a clone of Bug #460988 +++

This is just a reminder: 
npviewer.bin in the future will need a dynamic link to libcurl of its own arch.  While npviewer.bin itself might not actually use any symbols in libcurl, certain plugins will have the expectation that they be there or they will simply crash.

We will need this in F-8+ and RHEL5+ nspluginwrapper.

--- Additional comment from wtogami@redhat.com on 2008-09-03 02:48:56 EDT ---

NOTE: Adding this actually creates no difference to the installed system since users would already have it installed for other reasons.  This just guarantees that it will work instead of leaving it up to chance.
Comment 1 RHEL Product and Program Management 2008-09-17 03:52:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Martin Stransky 2008-10-20 03:20:35 EDT
Honestly it's a problem in flash - firefox and other browsers don't require libcurl so i don't see any reason why nspluginwrapper should demand it just for the one broken plugin. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.