Bug 461039 - liberation-fonts >=1.04.2 have problems with some websites and gecko-1.8*
liberation-fonts >=1.04.2 have problems with some websites and gecko-1.8*
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n
Depends On: 460090
  Show dependency treegraph
Reported: 2008-09-03 12:03 EDT by Pacho Ramos
Modified: 2008-10-30 19:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-30 19:39:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
good.png (432.60 KB, image/png)
2008-09-03 12:03 EDT, Pacho Ramos
no flags Details
wrong.png (534.10 KB, image/png)
2008-09-03 12:04 EDT, Pacho Ramos
no flags Details

  None (edit)
Description Pacho Ramos 2008-09-03 12:03:50 EDT
Created attachment 315657 [details]

Description of problem:
At first, I am using liberation fonts on a Gentoo system, I have already tried to send this to https://fedorahosted.org/liberation-fonts/wiki but I am unable to login succesfully. I am using epiphany-2.22.3 built against xulrunner-1.8 and gnome-2.22, I have tried with "Sans" and "liberation sans" fonts, both with the same problem (and with size 10)

Gentoo ships an old set of liberation fonts (seems to really be liberation-fonts-0.2) but they work FINE with most of websites (at least, all I have tried), then, I have updated to 1.04.2 (and later to 1.04.90 with the same problem) and I have started to have problems with sites like:


I can reproduce this problem always, if I put the mouse pointer over a link bellow first titular (their size is a bit smaller than fist titular) only part of text is underlined, other part not

I attach two screenshots showing proper (with old liberation-fonts) and unproper behavior (with new)

This also occurs, for example, with:

Version-Release number of selected component (if applicable):
1.04.2 or superior

How reproducible:
Simply try to move mouse over links in mentioned webpages (not all links fail, maybe it could be related with size)

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Pacho Ramos 2008-09-03 12:04:44 EDT
Created attachment 315658 [details]
Comment 2 Caius Chance 2008-09-04 21:38:24 EDT
Could you try if this one could display correctly?

Comment 3 Caius Chance 2008-09-04 22:50:50 EDT
FYI, I locally tested the attached tarball at comment #2 is works for me:


The tarball has hinting fixes on Liberation Sans which might also resolve this bug.
Comment 4 Pacho Ramos 2008-09-05 05:57:34 EDT
Seems that it's only reproducible when using xulrunner-1.8 (I am still using it because of some webpages not being shown properly with xulrunner-1.9)

I have merged epiphany against xulrunner-1.9 and seems to work ok (even when old liberation fonts worked with both)

Then, Do you think this is a xulrunner problem or a liberation one?

Thanks a lot
Comment 5 Caius Chance 2008-09-07 20:06:50 EDT
Sorry, I am not too sure whether this is a xulrunner problem or a liberation one.

I was working on hinting bug #458592 and I am now eliminating hinting bugs on all other liberation-fonts on bug#460090. It might be relevant to the problem you have because the above bugs are sourced from data loss between 1.03 (0.2) and 1.04 (1.04.2).

If you insisted to use xulrunner-1.8, I would humbly request you wait for the next liberation release with lost hinting data refilled from 1.03 (0.2).
Comment 6 Pacho Ramos 2008-09-08 11:51:05 EDT
I will try with next release, don't worry :-), it's not too important as I will need to switch to xulrunner-1.9 anyway when mozilla stops supporting 1.8
Comment 7 Pacho Ramos 2008-09-17 05:18:26 EDT
.91 release also has the same problem :-(
Comment 8 Caius Chance 2008-09-17 22:34:03 EDT
Hi Pacho, thank you very much for your timely testing feedback. 

Atm, all the Latin and frequently used characters have been reconfirmed by me, if they are holding hinting instructions. Afaik, they are all with original good hinting data.

When the font has problem, it might be more likely happens on specific codepoint (character) instead of whole line. In this case, rendering engine (xulrunner) might be struggling to create an underline of correct length when the mouse cursor hover on the link. I also found that in the wrong-sample screenshot the link texts are in bold. Because Liberation Fonts has font style (Bold, Italic, BI, Regular) in separated file, I would be even more believing that the link texts are re-rendered. Of course, I would not say that liberation-fonts has no effect on this problem.

I guess we could also notify this to xulrunner and epiphany upstreams about this issue, too. They may also be able to provide us valuable info.

Let's keep this bug opened at the moment.
Comment 9 Pacho Ramos 2008-09-18 05:10:40 EDT
The problem is that xulrunner-1.8 will be deprecated in december by moizlla (if I am not misremembering), and I am not sure if epiphany is still maintaining backend for this version, then I will ask on IRC if possible
Comment 10 Caius Chance 2008-09-18 20:04:45 EDT
(In reply to comment #4)
> I have merged epiphany against xulrunner-1.9 and seems to work ok (even when
> old liberation fonts worked with both)
> Then, Do you think this is a xulrunner problem or a liberation one?

Because the conversion from old liberation-fonts version (1.03) to new version (1.04) is not a perfect conversion. That was done by fontforge but it has been discovered there are data loss. The possible lost data are:

- Proprietary tables defined in OpenType format.
- Current flaws of fontforge.

For the latter issue, I have just fixed the missing hinting instructions of certain glyphs. I will keep fixing more issues of latter, too.

For the former issue, it is more rely on available tools and the current fontforge could not do it perfect enough.
Comment 11 Pacho Ramos 2008-09-19 04:33:00 EDT
OK, thanks for info :-)

I asked for help yesterday on epiphany IRC channel and they couldn't help me, then, if this cannot be fixed, I will simply wait for deciding to use xulrunner-1.9
Comment 12 Caius Chance 2008-09-21 21:47:40 EDT
Then when you see latest xulrunner acceptable for displaying your website, please kindly close this bug report. Thanks.

(In reply to comment #11)
> I asked for help yesterday on epiphany IRC channel and they couldn't help me,
> then, if this cannot be fixed, I will simply wait for deciding to use
> xulrunner-1.9
Comment 13 Caius Chance 2008-10-24 01:26:36 EDT
Hi Pacho, I have updated the liberation-fonts on:

https://fedorahosted.org/releases/l/i/liberation-fonts/ (1.04.92.devel)

Please feel free to test if you like and let me know. :)
Comment 14 Pacho Ramos 2008-10-25 06:05:40 EDT
It has the same problem (just tested this morning)
Comment 15 Caius Chance 2008-10-26 20:15:11 EDT
Hi Pacho, so we might need to move on to xulrunner-1.9 at the moment. How's your findings from users on IRC?
Comment 16 Pacho Ramos 2008-10-27 17:31:37 EDT
I haven't had much time for finding people on IRC, but I think that this could be closed as there is no problem with xulrunner-1.9 (also, mozilla usually fixes bugs after many time, then, I don't expect to get it fixed in xul-1.8)

Do you agree with closing this as it works with xul-1.9?


Note You need to log in before you can comment on or make changes to this bug.