Bug 461095 - Suspend to RAM fails to resume on ThinkPad T61
Suspend to RAM fails to resume on ThinkPad T61
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-09-04 01:02 EDT by James Cassell
Modified: 2013-01-10 02:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 13:11:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Cassell 2008-09-04 01:02:01 EDT
Description of problem:
When I suspend to RAM, everything appears to go fine.  When I open my computer, nothing happens.  When I press the power button, nothing happens.  The "suspend" light is still lit, but nothing will get the computer to come back on. (Though, pressing and holding for 4 seconds will make it go completely off.)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. System -> Shut Down -> Suspend
2. Wait for system to power down
3. try to revive system
Actual results:
nothing will get the computer to power back up

Expected results:
when I open the lid, or at the very least, press the power button, the computer should come back on, as it does in kernel

Additional info:
Suspend to disk, or "Hibernate" works fine.
I have the nvidia driver from the livna repo, so I don't know if this is their fault or not.
Comment 1 James Cassell 2008-09-23 18:18:12 EDT
kernel- is the last kernel that suspends and wakes up properly (relative term)

this problem still exists in
Comment 2 Noel J. Bergman 2008-10-22 13:14:32 EDT
Also fails with T61p (6457-7WU), and worked previously.
Comment 3 Noel J. Bergman 2008-10-29 15:08:49 EDT
For what it is worth, resume from suspend to RAM largely works in Fedora 10, although I found and reported two defects.
Comment 4 Chuck Ebbert 2008-11-01 20:32:54 EDT
Does the kernel headed for updates-testing work?

Comment 5 James Cassell 2008-11-01 23:56:43 EDT
no, it's still the same problem
Comment 6 Simo Sorce 2008-11-07 13:41:41 EST
Try waiting for 5 minutes or more, see my comment on https://bugzilla.redhat.com/show_bug.cgi?id=468663#c10 I think these may actually all be really the same bug.
Comment 7 James Cassell 2008-12-15 18:03:28 EST
This problem no longer exists in Fedora 10 (and I'm not using Fedora 9 anymore on this computer.)
Comment 8 Bug Zapper 2009-06-09 22:37:12 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 9 Bug Zapper 2009-07-14 13:11:43 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.