Bug 461140 - NetworkManager does not start under anaconda
NetworkManager does not start under anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 10:49 EDT by Orion Poplawski
Modified: 2008-09-10 13:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 13:24:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-09-04 10:49:30 EDT
Description of problem:

Starting with anaconda in case it's an issue the the anaconda supplied environment.

Doing pxe/ks boot.  

VT1:

waiting for hardware to initialize...

VT3:

getting kickstart file
only have one network device: eth0
sending dhcp request through device eth0
starting NetworkManager (1749) for eth0
ERROR: failed to start NetworkManager (6)

VT4:
<WARN> nm_generic_enable_loopback(): error -17 returned from rtnl_addr_add():
Success
<info> Trying to start the supplicant...
<info> Trying to start the system settings daemon...

the last two repeat every 2 minutes.

Version-Release number of selected component (if applicable):
11.4.1.30

How reproducible:
Everytime
Comment 1 Chris Lumens 2008-09-04 10:54:23 EDT

*** This bug has been marked as a duplicate of bug 461071 ***
Comment 2 Orion Poplawski 2008-09-09 15:02:41 EDT
Really don't think this is a duplicate, no traceback involved.

Only seeing on x86_64.  Same basic errors on VT3, VT4 has a little more:

<WARN> nm_generic_enable_loopback(): error -17 returned from rtnl_addr_add():
Success
<info> eth0: driver is 'e100'
<info> Found new Ethernet device 'eth0'
<info> (eth0): exported as /org/freedesktop/Hal/devices/net_00_19_d1_04_01_2d
<info> Trying to start the supplicant...
<info> Trying to start the system settings daemon...
<info> (eth0): device state change: 1 -> 2
e100: eth0: e100_watchdog: link up, 100Mbps, full-duplex
<info> (eth0): bringing up device.
<info> (eth0): preparing device.
<info> (eth0): deactivating device.
<info> (eth0): carrer now ON (device stae 2)
<info> (eth0): device state change: 2 -> 3

... then the two Trying lines again every 2 minutes.

VT3 error is now:
ERROR: failed to start NetworkManager (9)
Comment 3 Chris Lumens 2008-09-09 15:09:06 EDT
Yep, I just noticed this as well on x86-64.  Looks like a bunch of libraries weren't being included on 64-bit platforms.  I've committed a fix, and the next build should work.
Comment 4 Orion Poplawski 2008-09-10 13:24:19 EDT
Okay, working today.  I see:

nm-system-settings: <WARN> nm_utils_uuid_generate_from_string(): error generating UUID: (9) Failed to initialize the MD5 context: -8128

but the interface is up and running.
Comment 5 Chris Lumens 2008-09-10 13:34:13 EDT
I think that's due to us not pulling libsqlite.so into the initrd, which I thought I had fixed up but apparently not.  Let's see if tomorrow is correct.

Note You need to log in before you can comment on or make changes to this bug.