This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 461071 - dbus exception in loader, org.freedesktop.NetworkManager not provided
dbus exception in loader, org.freedesktop.NetworkManager not provided
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
: 461212 461804 461878 (view as bug list)
Depends On:
Blocks: F10Beta/F10BetaBlocker
  Show dependency treegraph
 
Reported: 2008-09-03 19:17 EDT by Jesse Keating
Modified: 2013-01-10 11:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 18:55:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of the crash (16.81 KB, image/png)
2008-09-03 19:17 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jesse Keating 2008-09-03 19:17:33 EDT
Created attachment 315709 [details]
Screenshot of the crash

I think screenshots are the only way to explain this.  This is a compose of content from 20080903 (with a slightly newer 'cluster' package so that deps weren't broken).  This crash is just as it's trying to run loader.
Comment 1 Jesse Keating 2008-09-03 19:20:20 EDT
Sorry, it's when loader tries to launch anaconda, which is well after loader starts.
Comment 2 Chris Lumens 2008-09-04 10:54:23 EDT
*** Bug 461140 has been marked as a duplicate of this bug. ***
Comment 3 Mike Chambers 2008-09-04 13:02:58 EDT
Saw same thing this morning and an X86_64 system but running 386 install.
Comment 4 Chris Lumens 2008-09-05 10:50:52 EDT
*** Bug 461212 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2008-09-05 18:10:26 EDT
This should be fixed in the next build of anaconda, though there's still some fine tuning to do before network configuration works completely.
Comment 6 Andrew Farris 2008-09-10 17:06:55 EDT
The version of Anaconda this was first seen in is not posted here, but I'm still seeing it in the 20080910 composed boot.iso which has anaconda 11.4.1.32.
Comment 7 Jeremy Katz 2008-09-10 21:35:39 EDT
Yeah, I'm still seeing this booting from boot.iso.  Booting instead from kernel + initrd and pointing to stage2 over the network seems fine, though.
Comment 8 Andy Lindeberg 2008-09-11 10:44:35 EDT
*** Bug 461878 has been marked as a duplicate of this bug. ***
Comment 9 Chris Lumens 2008-09-11 18:55:53 EDT
This will be fixed in the next build of anaconda.  It helps when we start NM in
all cases, not just in the loader when networking is enabled.
Comment 10 Chris Lumens 2008-09-12 11:16:31 EDT
*** Bug 461804 has been marked as a duplicate of this bug. ***
Comment 11 John Reiser 2008-09-12 19:42:22 EDT
(In reply to comment #9)
> This will be fixed in the next build of anaconda.

"rawhide report: 20080912 changes" showed no paragraph for anaconda. A pungi-composed DVD that was made from today's rawhide (the freeze for Fedora 10 beta) failed very shortly after "Starting graphical interface" with the same symptom "The name org.freedesktop.NetworkManager was not provided by any .service files".
Comment 12 Jesse Keating 2008-09-12 20:08:30 EDT
Take a closer look?
https://www.redhat.com/archives/fedora-devel-list/2008-September/msg01153.html

anaconda-11.4.1.34-1
--------------------
* Thu Sep 11 18:00:00 2008 Chris Lumens <clumens redhat com> - 11.4.1.34-1
- Always start NM so we can talk to it in the boot.iso case (#461071).
  (clumens)
- Use the device path to identify LUKS devs in /etc/fstab. (#460700)
  (dlehman)
- Use the LUKS UUID instead of device nodes in all references. (#460700)
  (dlehman)
- LUKSDevice.getScheme() no longer cares if the dev has a passphrase.
  (#461203) (dlehman)
- Correct translation to fix the build. (clumens)
- Add the method string back into anaconda-ks.cfg. (clumens)
- Let's try pulling libsqlite into the initrd one more time. (clumens)
- Don't traceback at the end of live installs (katzj)
- Correct the message telling you to use a VNC password. (clumens)
- Remove unused TIMEZONES= crud. (clumens)
- print doesn't yet support the file= syntax in our version of python.
  (clumens)
- Catch errors from using the wrong bugzilla field and display them.
  (clumens)
- Fix line wrapping on part type screen (jlaska, #461759).
- rep_platform has been renamed to platform. (clumens)


I've done multiple installs with 20080912's content.  Please make sure you're using an up to date mirror.
Comment 13 Andrew Farris 2008-09-12 23:40:34 EDT
I also successfully installed natively and through vmware with 20080912 boot.iso.
Comment 14 Mike Chambers 2008-09-13 13:28:20 EDT
I got to the install GUI just fine this time and everything else went as normal, EXCEPT that when I got to the section to configure the network (static local network on built in ethernet port) I got error on both static , or it just kept repeating itself if I tried dhcp.

If not known, might need to do new bug?  Although I don't remember the exact error message.
Comment 15 John Reiser 2008-09-13 18:02:56 EDT
(In reply to comment #12)
> Take a closer look? ...

> I've done multiple installs with 20080912's content.  Please make sure you're
> using an up to date mirror.

I verified the problem exists on both i386(i686) and x86_64, the i386 composed at about noon PDT (1900 UTC) and the x86_64 at about 5pm (0000 UTC the following day.) The rawhide report for Friday was sent at 12:46:39 +0000 (UTC), which is 6 or 7 hours before my first run.

At about 1900 PDT I changed the rawhide-fedora.ks file to remove "--mirrorlist=..." and replace it with "--baseurl=...  pointing directly to download.fedoraproject.org.  The problem persisted.

Further investigation points at buildinstall leaking some of its data into the DVD.iso, instead of using the data from the anaconda*.rpm in "the" repo.  I have filed a new report at bug 462199 "composed DVD has old anaconda yet repo has new anaconda".

Note You need to log in before you can comment on or make changes to this bug.