Bug 461217 - gnome-settings-daemon fails with an assert in xrandr plugin
gnome-settings-daemon fails with an assert in xrandr plugin
Status: CLOSED DUPLICATE of bug 461152
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 21:46 EDT by Dennis Jacobfeuerborn
Modified: 2008-09-04 23:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 23:01:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2008-09-04 21:46:24 EDT
The gnome-settings-daemon fails with an assert in the xrandr plugin in when the latest version of gnome-desktop is installed:

** (gnome-settings-daemon:5433): DEBUG: Loading /usr/lib/gnome-settings-daemon-2.0/libxrandr.so
** (gnome-settings-daemon:5433): DEBUG: Registering GsdXrandrPlugin
** (gnome-settings-daemon:5433): DEBUG: Creating object of type GsdXrandrPlugin
** (gnome-settings-daemon:5433): DEBUG: GsdXrandrPlugin initializing
** (gnome-settings-daemon:5433): DEBUG: Activating xrandr plugin
** (gnome-settings-daemon:5433): DEBUG: Starting xrandr manager
**
ERROR:gnome-rr-config.c:677:configurations_free: assertion failed: (configurations != NULL)
Aborted

"gnome-rr-config.c" is actually a source file in the gnome-desktop package.

The result of this assertion is that the desktop does not get initialized with the proper settings (wrong keyboard layout, theme, etc.).

One way to fix this is to remove the file "/usr/lib/gnome-settings-daemon-2.0/libxrandr.so", the other is to downgrade the gnome-desktop package to "gnome-desktop-2.23.6-2.fc10.i386" (and the respective control-center package as a dependency).
Comment 1 Yanko Kaneti 2008-09-04 22:27:10 EDT
dup of bug 461152
fixed in koji builds from today
Comment 2 Matthias Clasen 2008-09-04 23:01:13 EDT

*** This bug has been marked as a duplicate of bug 461152 ***

Note You need to log in before you can comment on or make changes to this bug.