Bug 461251 - RHEL 5.1 full install can't be updated
RHEL 5.1 full install can't be updated
Status: CLOSED DUPLICATE of bug 428323
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.1
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: John Matthews
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 07:18 EDT by Rolf Kyburz
Modified: 2008-09-18 14:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 14:42:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolf Kyburz 2008-09-05 07:18:17 EDT
I'm rying to find out how our customers running RHEL 5.1 can possibly update their installation to current level. I installed RHEL 5.1, selecting ALL components, then ran the Software Updater utility (up2date, presumably); this downloaded the RPM headers, but then failed with the error message below. I know I can install 5.2 OK, but I'd like to find a solution for our customers that does NOT involve reinstalling the OS.

Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError: local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 557, in applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 322, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 153, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 760, in downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 461, in getHeader
    cache=cache,
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-client-5/getPackage/kdelibs-3.5.4-16.el5.i386.rpm
start: 440
url: None
text: None
self: rhel-x86_64-client-5
cache: True
reget: None
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-client-5
relative: getPackage/kdelibs-3.5.4-16.el5.i386.rpm
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''), ('X-RHN-Auth', 'a9GNi6ffm8Ynx9TIxmOjPw=='), ('X-RHN-Auth-Server-Time', '1220612056.76'), ('X-RHN-Server-Id', 1013687603))
checkfunc: (<bound method PackageUpdater.verifyHeader of <__main__.PackageUpdater object at 0x1f4e7690>>, (<yum.sqlitesack.YumAvailablePackageSqlite instance at 0x208de6c8>, 1), {})
copy_local: 1
end: 607984
local: //var/cache/yum/rhel-x86_64-client-5/headers/kdelibs-3.5.4-16.el5.i386.hdr
Comment 1 John Matthews 2008-09-18 14:42:30 EDT

*** This bug has been marked as a duplicate of bug 428323 ***

Note You need to log in before you can comment on or make changes to this bug.